• The Gear Page Apparel & Merch Shop is Open!

    Based on member demand, The Gear Page is pleased to announce that our Apparel Merch Shop is now open. The shop’s link is in the blue Navigation bar (on the right side), “Shop,” with t-shirts, hats, neck buffs, and stickers to start. Here’s the direct link: www.thegearpageshop.com

    You’ll find exclusive high-quality apparel and merchandise; all items are ethical, sustainably produced, and we will be continuously sourcing and adding new choices. 

    We can ship internationally. All shipping is at cost.


Need help to savage my EMG American Strat

major

Member
Messages
68
Hi all, Ok, here's my situation, I have a Lonestar strat with the EMG pickguard that David Gilmour put his name on it, the DG-20. It appears by my testing that the volume control, EXG,SPC and 5 way selector have gone bad, microphonic. With volume at 10, I get alot of low static noise and as I tap on the volume knob, 5 way selector its loud through the speakers. with my other guitar, active EMG's-no problem, very quiet. I'm guessing the the built in preamp has gone bad, so I would still like to use the 3 SA single coil pickups that's in the setup. The volume overall has been weak for the last month, as I think the preamp was slowing going down. Yes, I replace the battery with a new one, no difference. Is it worth it to strip the electronics down and install all new pots with these pickups? Are there any schematics to help me rewire the strat? My original pickguard came with a Seymour Duncan Pearly Gates humbucker and 2 Texas Specials that sounded weak and humed. What do you all think?
 

walterw

Platinum Supporting Member
Messages
38,466
it's unlikely everything went bad all at once.

first, make sure all the pots, pickups, and booster circuits are grounded. then, try bypassing the two booster circuits by running a wire straight from the volume pot's center lug to the output jack.
 

Kyle Ashley

Silver Supporting Member
Messages
2,742
I have noise issues with my DG20 guitar too. basically the same kind of thing you described. Crackling and static mainly in the volume knob, and some in the midrange control. I've found that blasting some compressed air into the pots every couple of months clears things out, and they work well again for a little while, but it did become enough of an annoyance that I built another Strat with Kinman PUs.
 

major

Member
Messages
68
Thanks Walter for your suggestion. I will try that tomorrow, I'll let you know the results. Kyle sorry for you on having the same noise issue. Its really too bad, because I really liked the overall setup in my strat using the exc, and spc preamp boosters. $300 is alot of money for not lasting more than a year before issues begin to pop up. I never have had any pickup problem once installed, ocasionally a few pots stop working or get too dirty, they need to be replaced, but that's it.
 




Trending Topics

Top