• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

Need help w/ amp problem

washuffitze3

Member
Messages
193
I put in new tubes in my Fender Blues Jr about 2 months ago and it recently started making cracklin noises. Now i turn it on and with the Master volume at 5 and Volume at almost 3 (which usually yields a nice, sparkly, fender clean tone) produces a very overdriven sound. Not sure why this is, but i have a gig on friday and would love to get it sorted out before then.

Thanks in advance!
 

vibrasonic

Member
Messages
1,869
Tubes probably.

A lot of new tubes are prone to premature failure. Could be something else but i'd start with trying new tubes. Also try tightening the tube sockets.
 

vibrasonic

Member
Messages
1,869
Sometimes it hard to see the preamp tube light up. Turn off all the lights in a dark room
and you'll probably see some light from them. Do you have an extra 12ax7 to try? If they are only 2 months old bring your amp in to where you bought the tubes and they might be able to help you out with new ones.
 

washuffitze3

Member
Messages
193
I just wiggled around the EL-84s and it got clean again. Weird.i hope this solves the problem. Could it be they arent in all the way or were just moved slightly to a direction, messing it up??
 

chervokas

Member
Messages
6,839
It only seems to be the power tubes lighting up when its making the crackling sound
Do you mean the power tube plates are starting to glow? If they're red plating they're drawing too much current. Is the bias adjustable on that amp? If so you should try to rebias so they're not drawing so much current. If not definitely get those tubes out of there are try a new set before you take out some other components.
 

guitarjazz

Member
Messages
23,133
I tried to put three sets of new power tubes in one of my Boogies and it sort of did the same thing as your amp. Turns out there was a problem with the socket and circuit board that was only made evident by me taking the old (working!) tubes out.
Take your amp to a tech.
 

washuffitze3

Member
Messages
193
Do you mean the power tube plates are starting to glow? If they're red plating they're drawing too much current. Is the bias adjustable on that amp? If so you should try to rebias so they're not drawing so much current. If not definitely get those tubes out of there are try a new set before you take out some other components.
Ya one of the power tube is glowing orange. I dont believe my amp has a bias adjustment on it..not really my field of expertise (amps/tubes/etc). I guess i will take it to a tech.
 






Trending Topics

Top Bottom