Need some OCD v.3 help!!!!!

dirty145

Member
Messages
491
I was playing a show last weekend and my OCD crapped out on me. I have the version 3 and it is in an MKS Pedalpad 2 and well protected. Anyway, here is the problem;

When I step on the box, the light comes on, but no sound. If I step on it hard, sometimes the sound comes through fine. I don't think that it is a patch cable, because when the pedal is disengaged there are no problems. Does anyone know what this could be and how to fix it?
 

WailinGuy

Member
Messages
1,363
Most likely the footswitch went bad. This is not uncommon with those 3PDT (9 terminals) switches. You probably have a choice of either sending back to Fulltone for repair, or having them send you a new switch and replacing it yourself (or having a friend with soldering skills do it).
 

telemike

Member
Messages
595
Call them and get a Return Authorization. They will fix it for the cost of postage. Same thing happened to mine. Works like a charm now.
 

dirty145

Member
Messages
491
If it were the switch, would it still be turning on and off. The light does come on every time I click it, I just get sound about 50% of the time.
 

Pedro58

Silver Supporting Member
Messages
6,491
Yes, the light could function independently of the signal switching. They are on different poles on the switch. You could also have a cold solder joint at the switch or one of the input/output jacks.
 

pedalitis

Member
Messages
309
have experienced similar issues with my other pedals. yeah its prob a footswitch problem dude. just get it replaced. cheap fix. youll be good to go.
 

rastaman

Member
Messages
2,100
If it were the switch, would it still be turning on and off. The light does come on every time I click it, I just get sound about 50% of the time.

With electronics there is a little thing called resistance. Whether it's being caused elecrically or mechanically it really doesn't matter. If the switch contacts have over .5 ohms of resistance, or they are not wiping themselves clean, or they are not positioned properly, or.... any number of reasons - the sound will cut in and out and/or swell in and out. You could check the solder connections but I would get the switch replaced.

FWIW, the first OCD V3 I bought was doing the same thing. I returned it and they sent me a new one.
 

PremiumPlus

Member
Messages
1,150
I had the same thing happen to my Rat. Some DeOxit sprayed down the shaft of the switch (wipe the shaft clean first) and switching it about 50 times did the trick for me. That was 5 years ago. The contacts do develop resistance or oxidize with some of these switches.
Try that to get you by until you can get a replacement switch or send it back.
 




Trending Topics

Top Bottom