Peavey Classic 50 question

Discussion in 'Amps and Cabs' started by joel98z, Jan 22, 2008.

  1. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007
    Maybe a dumb question but when using the drive chanel, is it using tubes in both V1 and V2, or just V2?
     
  2. alivegy

    alivegy Member

    Messages:
    1,060
    Joined:
    Dec 31, 2007
    Location:
    SoCal
    both, cascading gain stages. There is a cap on v2 that bleeds most of the lowend out so I don't end up using that channel at all.
     
  3. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007

    OK that makes sense.. My drive channel sounds really bad so I tried to swap tubes in V2, and it sounded the same. I guessing that swapping the tube in V1 will help as well..
     
  4. Melodic Dreamer

    Melodic Dreamer Member

    Messages:
    5,935
    Joined:
    Aug 15, 2005
    The Classic 50 also needs a speaker change.
     
  5. Lucidology

    Lucidology Member

    Messages:
    25,719
    Joined:
    Aug 14, 2006
    Location:
    Monterey, CA
    OMG... My Stock Peavey Classic Drive channels all sound excellent...
    Great chewy, fluid sound (just put a nice compressor in front of it) ..

    See what ya think ... check it out here:

    Norwegian Wood (Got YouTubed) - The Gear Page
     
  6. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007

    What do you recomend?
     
  7. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007
    That sounds good.. Mine does not sound that nice..

    There is something wrong with mine, if I turn the pre gain up past 5-6 it sounds real raspy and harsh.. No definition in highs, lows are real muddy.. It did not use to sound like that..

    How was you amp set in that video?
     
  8. gkoelling

    gkoelling Member

    Messages:
    15,534
    Joined:
    Nov 25, 2005
    Location:
    In The Basement

    How old are your tubes? Maybe you need a fresh set.
     
  9. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007
    About 5 years old.. I got a set of JJ's on the way now.. :AOK
     
  10. buddaman71

    buddaman71 Student of Life Silver Supporting Member

    Messages:
    11,395
    Joined:
    Jan 16, 2008
    Location:
    OKC, OK
    I have a 10 year-old dead stock Classic 50 and I LOVE the drive channel.

    Also, FWIW, I can really get a good Keith Urban tone with my EMG-loaded Yamaha tele copy through the C50 as well.
     
  11. recto-robbie

    recto-robbie Member

    Messages:
    2,307
    Joined:
    Jun 19, 2007
    Location:
    Chicago Burbs
    I love the drive channel on mine also,,, ive also got a fresh set of power tubes coming from eurotubes as we speak. I bet that your problem with the sound.

    Ive never really messed with the tubes in any of the classic 50's ive owned, havent needed to,, so this will sound like a stupid question;;;

    which preamp tube is v1??? looking at the back of the amp,, is it the preamp tube farthest to the right??? closest to the guitar input???
     
  12. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007
    Yep, V1 is on the far right when looking at the back.. V3 is closet to the power tubes.
     
  13. Lucidology

    Lucidology Member

    Messages:
    25,719
    Joined:
    Aug 14, 2006
    Location:
    Monterey, CA

    Thanks Joel ...

    In that youtube I'm using a Boss DD-3 in the loop
    & a compressor (Maxon CP101) in front ...

    Bass at 3, Treble at 3, Mid's at 1, Presence at 1 ..
    The compressor really smooths out the OD channel
    (I don't know know if you've tried that yet) ..
    But as you can see, my settings are pretty conservative ...
     
  14. teefus

    teefus Silver Supporting Member

    Messages:
    7,737
    Joined:
    Mar 15, 2004
    there are some mods listed on the blueguitar.org site that were derived from the c30 mods. they make a world of difference although the c50 chassis is a little more difficult to get into.
     
  15. Home Grown Tele

    Home Grown Tele Member

    Messages:
    316
    Joined:
    Sep 6, 2006
    Location:
    Queens, NY
    I put a set of Eminence Swamp Thangs in mine and it sounds 100% better.

    I'd think that Eminence Red, White and Blues would sound great too.
     
  16. recto-robbie

    recto-robbie Member

    Messages:
    2,307
    Joined:
    Jun 19, 2007
    Location:
    Chicago Burbs
    How hard is it to swap speakers in the classic 50???? I assume you would need to take out the head regardless,, correct????
     
  17. southpawmax

    southpawmax Member

    Messages:
    457
    Joined:
    Jun 9, 2007
    Location:
    Brooklyn, NY
    Could I hear more about that? Have you experimented with changing the value of that cap and do you know what works best?
     
  18. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007

    Just looking at mine, it seems as though the amp will have to come out for a speaker swap..
     
  19. Marshall Man

    Marshall Man Member

    Messages:
    1,130
    Joined:
    Jan 7, 2008
    Location:
    Tampa Florida
    I have Classic 50 combo as well. I was on the verge of dumping it, but then I plugged it into my Avatar cab and it sounds pretty damn good now. Mine is all stock bought new a year ago. I do use a TS-9 in front for some extra drive when needed.
     
  20. joel98z

    joel98z Member

    Messages:
    567
    Joined:
    Dec 7, 2007
    What speakers are in your cab, and were you running the stock speakers as well?
     

Share This Page