Peavey Triumph not turning on

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by jeffsheasley, Jan 30, 2012.

  1. jeffsheasley

    jeffsheasley Member

    Messages:
    4
    Joined:
    Jan 30, 2012
    My friend turned on my Peavey Triumph 120 without plugging it into the cab first. It lit up for a second and turned off and hasn't turned on since then. I checked the fuses and none look blown but I'm replacing them all just to check. Any other ideas on what could have happened?
     
  2. dazco

    dazco Member

    Messages:
    11,606
    Joined:
    Jul 25, 2003
    Those have internal fuses too in case you didn't know. Gotta remove the chassis to get to them. I had that amp back in the late 80's and i remember it blew a fuse at a gig that was inside.
     
  3. jeffsheasley

    jeffsheasley Member

    Messages:
    4
    Joined:
    Jan 30, 2012
    I found the blown one tucked away in a corner. Now if I could only find somewhere that carries the one I need to replace. A ceramic 1a.
     
  4. cap47

    cap47 Member

    Messages:
    2,244
    Joined:
    Sep 16, 2009
    Location:
    Bushnell, FL
    You don't need to use a ceramic, just match the value! If it is fast blo use the same or timed use the same.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice