1. A proposal is now up as a poll to change the guidelines of TGP to only allow member self-deleting of post/threads for up to thirty days of the original posting it. We are now watching the poll here. Click here to view the thread.

    Dismiss Notice

Peavey XR684 - no fx help

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by prsnstrat, May 23, 2011.

  1. prsnstrat

    prsnstrat Member

    Messages:
    1,898
    Joined:
    Nov 29, 2005
    Would like to know if anyone has had this issue with theirs. We use for rehearsals and if the gig is small enough. The reverb/delays are not there in any capacity in any channel. Thanks in advance for any insight.
     
  2. davemccarthy707

    davemccarthy707 Member

    Messages:
    1,058
    Joined:
    Oct 4, 2008
    Location:
    Newfoundland
    Did you check the reverb pan and connections.
     
  3. Ronsonic

    Ronsonic Member

    Messages:
    3,306
    Joined:
    May 14, 2006
    Location:
    Sunny Tampa, Florida
    I've never seen anything go wrong with those except for mechanical / connection issues. The most rugged box mixer ever produced.
     
  4. prsnstrat

    prsnstrat Member

    Messages:
    1,898
    Joined:
    Nov 29, 2005
    Ronsonic I totally agree with you...it's gotta be a fluke! It could be just some corrosion on one of the contacts.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice