Peterson Stobostomp HD Issues

Discussion in 'Effects, Pedals, Strings & Things' started by Leftyman, Jan 14, 2020.

  1. Leftyman

    Leftyman Gold Supporting Member

    Messages:
    1,542
    Joined:
    Dec 20, 2008
    Location:
    Nebraska
    I recently purchased the Strobostomp HD after looking at reviews on youtube and TGP which all seem to be positive.

    After spending a week with this thing, I do not care for it. Yes, the display is big and easy to read but it reminds me of my old computer monitor from 20 years ago. Poor resolution and glitchy. I am also not a fan of the lag when switching on and off.
     
    Last edited: Jan 14, 2020
  2. soma

    soma Member

    Messages:
    927
    Joined:
    Oct 27, 2009
    Location:
    London, UK
    Mine is brilliant. Maybe swap it for another?
     
    teefus, Scott57 and Stomp like this.
  3. Blix

    Blix Supporting Member

    Messages:
    23,224
    Joined:
    Mar 11, 2010
    Location:
    Stabekk, Norway
    Your thread title needs some fixing.
     
  4. burton56

    burton56 Member

    Messages:
    544
    Joined:
    Feb 6, 2019
    So you do like it? Or you don’t like it? I’m getting mixed signals here.
     
    brs928 likes this.
  5. Platypus

    Platypus not in rivers, but in drops Supporting Member

    Messages:
    2,564
    Joined:
    Mar 10, 2006
    Location:
    City of Big Shoulders
    That's unfortunate to hear, I still have the original big blue pedal version and it's perfect. I really hope it lasts forever.
     
    Stomp likes this.
  6. moore_for_less

    moore_for_less Supporting Member

    Messages:
    1,705
    Joined:
    Jul 8, 2016
    Location:
    Home, home again… I like to be here when I can…
    The lag is unfortunate, but really not that bad. Once you get used to allowing for those few milliseconds, it’s like second nature. And it prevents popping through the signal chain.

    I don’t find the display glitchy though, very smooth for me. What makes you say that?
     
    Stomp likes this.
  7. Leftyman

    Leftyman Gold Supporting Member

    Messages:
    1,542
    Joined:
    Dec 20, 2008
    Location:
    Nebraska
    That's just how it seems to me however, after watching a few more videos I'm now wondering if there is something wrong with mine. The display seems sloppy if that makes any sense.
     
    Last edited: Jan 14, 2020
  8. ratedepth

    ratedepth Member

    Messages:
    139
    Joined:
    Jan 26, 2017
    Thread title is missing a “not”.

    Typo aside, I concur that the tuner kinda sucks
     
  9. Leftyman

    Leftyman Gold Supporting Member

    Messages:
    1,542
    Joined:
    Dec 20, 2008
    Location:
    Nebraska
    I appreciate it, I obviously didn't notice.
     
  10. wetordry

    wetordry Member

    Messages:
    4,315
    Joined:
    Mar 8, 2015
    Location:
    virginia mountains
    Have you considered buying a different tuner?

    As to the Peterson, i just leave it on.
     
  11. Adagietto

    Adagietto Supporting Member

    Messages:
    2,923
    Joined:
    Feb 10, 2012
    Location:
    Area 52
    You might contact Peterson as their support seems really good. E.g., I found a little bug in the SSHD and they had new firmware out in a few days. A couple of years ago I got a StroboClip HD that wasn't sensing properly, and they sent out a new one immediately. The replacement has been working properly ever since, and I use it constantly. [Not to mention that I disliked every clip-on I'd tried before that.]
     
  12. Adagietto

    Adagietto Supporting Member

    Messages:
    2,923
    Joined:
    Feb 10, 2012
    Location:
    Area 52
    That's what I do, but I'm using an Empress Buffer+. It has a tuner output and a mute. I like an always-on tuner, been doing that for years.
     
    wetordry likes this.
  13. Stox

    Stox Member

    Messages:
    216
    Joined:
    Jan 3, 2011
    In the output of my volume pedal, no lag, no glitchiness, display is crisp and sharp. It’s a great tuner all the way around.

    Sounds like you got a bum one.
     
    CEFlint and Adagietto like this.
  14. Leftyman

    Leftyman Gold Supporting Member

    Messages:
    1,542
    Joined:
    Dec 20, 2008
    Location:
    Nebraska
    I ordered it through Amazon. The owners manual states that orange is the default color. Is this correct. Mine was not orange.
     
  15. cap10kirk

    cap10kirk Member

    Messages:
    7,289
    Joined:
    May 9, 2015
    Location:
    Mid-Atlantic US
    A glitchy display sounds to me like you possibly just got a bad one. However, they all have that delay from the time you step on the switch until it actually mutes. That was enough of an issue to make me dislike it, I've never had another tuner that did that.
     
  16. Adagietto

    Adagietto Supporting Member

    Messages:
    2,923
    Joined:
    Feb 10, 2012
    Location:
    Area 52
    Mine was orange. You might go through the settings to see what else may not be default. Perhaps you got a "demo"? You could try doing a factory reset, although it seems that would have little to do with a glitchy display.
     
  17. Dominik

    Dominik Member

    Messages:
    316
    Joined:
    Oct 30, 2019
    Return it and consider buying a Turbo Tuner. It's also made in the USA.
     
  18. Leftyman

    Leftyman Gold Supporting Member

    Messages:
    1,542
    Joined:
    Dec 20, 2008
    Location:
    Nebraska
    I have a Turbo Tuner on my main board. I purchased this for another board mainly because I need a buffer. I did do a firmware update and the display is much better. The switch still bothers me but I might be able to get use to it. I've done a bunch of research and the choices seem to be pretty limited when it comes to buffered tuners. I am not a fan of the Polytune nor the Boss tuners which is all I could find.
     
    Adagietto and Dominik like this.
  19. Dominik

    Dominik Member

    Messages:
    316
    Joined:
    Oct 30, 2019
    Understandable and glad to hear the firmware update was an improvement. Hopefully a switchable buffer circuit is added to the next version of the Turbo Tuner.
     
  20. AltecGreen

    AltecGreen Silver Supporting Member

    Messages:
    843
    Joined:
    Sep 29, 2015

    Check out the Providence STV-1JB System Tuner. It's a modified Korg Pitch Black tuner with Providence's Vitalizer buffer circuit.

    http://www.providence-ltd.com/feature_01.html#stv
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice