Powering up a NOVA

Discussion in 'Effects, Pedals, Strings & Things' started by Steve Gambrell, Jul 28, 2008.

  1. Steve Gambrell

    Steve Gambrell Member

    Messages:
    982
    Joined:
    Oct 8, 2007
    I just traded some stuff for a TC Electronic NOVA delay. Now, is there any simple way to get the 12 VDC the NOVA wants out of my GAtor power supply?
     
  2. Bluewail

    Bluewail Tone curmudgeon Silver Supporting Member

    Messages:
    1,575
    Joined:
    May 2, 2003
    Location:
    Pacifica, CA
    I'm running my Nova Delay off a OneSpot 9V supply without problem. There is enough rgulation in the TC to make it work perfectly. The TC does suck dome current though so if the overall current draw of your power supply gets too low, you'll have problems with some pedal or another not powering up. No harm can be done to the TC Nove at 9V.
     
  3. Steve Gambrell

    Steve Gambrell Member

    Messages:
    982
    Joined:
    Oct 8, 2007
    How long have you been doing this? I figured it wouldn't cause any harm, but the NOVA might not do some things correctly. My board will have a tuner, compressor, a Voodoo Lab SparkleDrive, an MXR Carbon Copy, and the Nova.
    Thanks for the help!
     
  4. saucyjack

    saucyjack Member

    Messages:
    688
    Joined:
    Aug 18, 2006

    Same here.Running the Nova(and whole board)with a one spot for about 6 months.
    I did have a one spot go bad after a few months of doing this but it was 2-3 years old so it just may have been time for it to die.
     
  5. Bluewail

    Bluewail Tone curmudgeon Silver Supporting Member

    Messages:
    1,575
    Joined:
    May 2, 2003
    Location:
    Pacifica, CA
    I only got the Nova Delay recently so it's been a few weeks. The Nova works identically with either the OneSpot or the original 12V supply. I'd say just wire it up and turn them all on. If you've sapped all the available current, you'll hear it in one or more pedals.
     
  6. thesjkexperienc

    thesjkexperienc ^^^ I made this guitar^^^

    Messages:
    3,476
    Joined:
    Jul 21, 2008
    Location:
    Colorado mountains
    I have 2 nova pedals and the powerup just fine on some of the 9 volt outlets on my voodoo power supply, but not all. I cant figure out why.
     
  7. cbpickin

    cbpickin Tweed Supporting Member Silver Supporting Member

    Messages:
    6,375
    Joined:
    Jan 18, 2006
    Location:
    Central Coast, CA
    Because some of the outlets put out more mA than others. I can't remember for sure, but I think it is the last two outlets (on the right if you're facing the unit). If you flip the dip switches, you can run them at 12V also I believe. I'd have to check my manual to be sure though.
     

Share This Page