• The Gear Page Apparel & Merch Shop is Open!

    Based on member demand, The Gear Page is pleased to announce that our Apparel Merch Shop is now open. The shop’s link is in the blue Navigation bar (on the right side), “Shop,” with t-shirts, hats, neck buffs, and stickers to start. Here’s the direct link: www.thegearpageshop.com

    You’ll find exclusive high-quality apparel and merchandise; all items are ethical, sustainably produced, and we will be continuously sourcing and adding new choices. 

    We can ship internationally. All shipping is at cost.


Princeton Reverb breaking up at 2.5??

mingo

Member
Messages
430
I have a silverface princeton reverb amp that sounds amazing until you get it over volume level 2. Then it starts breaking up, way too early for me. Any ideas what could be wrong?

Here's the details on the amp. Master volume circuit taken out, paulc and phase inverter mod done, tube sockets in the power tubes and rectifer replaced, speaker in a year old (emminence), caps replaced.

Thanks
 

mingo

Member
Messages
430
So is this it (far right in the back of the amp??

V1 12ax7 = Preamp
V2 12at7 = Reverb send
V3 12ax7 = 1/2 Reverb recovery and 1/2 Reverb mix
V4 12ax7 = 1/2 Vibrato and 1/2 Phase inverter
V5 6V6 = Power tube #1
V6 6V6 = Power tube #2
V7 5U4GB = Rectifier tube

Thanks
 

RupertB

Silver Supporting Member
Messages
4,316
Sorry for the stupidity, but i don't know which one that is. I know the Rectifier is far left then two power tubes, and that's it. Is the first preamp valve right after the power tubes??

Does the amp chart tell you this stuff
Yes, it does. V1 is the small preamp tube farthest away from the larger power & rectifier tubes.

The farthest right in this picture.


If a tube swap doesn't fix it, it wouldn't hurt to have someone check/adjust the bias as well.
 

mingo

Member
Messages
430
Thanks for all the help.

I just replaced the tube with another 12AX7 (i don't have a 5751 on me) and its still distorting, i'm gonna have to take it to someone.
 

mingo

Member
Messages
430
Anyone know if the PaulC mod would help this?

Also it is a push pull model, does it have a linear pot on the volume? If so would an audio pot help with this at all??
 

dividedsky

Member
Messages
4,265
Sounds like something is wrong to me and not something that will be fixed with mods. It simply should not be breaking up that early.
 

mingo

Member
Messages
430
Sounds like something is wrong to me and not something that will be fixed with mods. It simply should not be breaking up that early.
Happens with a humbucker guitar, not bad with single coils.

There's a new output transformer in there, tubes are good, new cap can, some new resistors/capisiters.

Any idea what it could be?
 

sinasl1

Silver Supporting Member
Messages
8,833
It's normal for a humbucker guitar to make an amp like that distort at that level. I can make almost any amp distort even when set real clean, if i use a bridge humbucker and hit the guitar hard.
 

LHanson

Member
Messages
7,759
It's normal for a humbucker guitar to make an amp like that distort at that level. I can make almost any amp distort even when set real clean, if i use a bridge humbucker and hit the guitar hard.
Agree. Many times, clean is at the guitar volume control. If you want loud, super-clean tones, a Princeton isn't the amp for you. Try this:

Set the amp to about 7. Turn the volume completely off at the guitar. Gradually bring the guitar volume up, and see where it breaks up.
 

dividedsky

Member
Messages
4,265
It's normal for a humbucker guitar to make an amp like that distort at that level. I can make almost any amp distort even when set real clean, if i use a bridge humbucker and hit the guitar hard.
Glad that has not been my experience with PRs. Maybe I'm just not that heavy handed but I always play with my guitar on 10 and don't have any issues with mine breaking up that early.
 

Ginglymus

Member
Messages
1,114
Anyone know if the PaulC mod would help this?
It might, but according to your OP, that's already been done. If break-up at 2.5 with humbuckers is your main issue, I'd recommend trying one or more 5751s as 12AX7 subs.
 




Trending Topics

Top