• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

Questions regarding Temple Audio boards

spod

Member
Messages
318
I have the Trio 43 with a decent number of pedals on it. I did see some flex initially but on the left hand side, I have my ES8 top-mounted using the plates which seems to reinforce it somewhat. On the right hand side, I mounted my Zuma power supply underneath which did the same on that side so it's certainly avoidable. I did get some chipping of the paint but it's largely from trying to line up the plates....the little circular part on the underside of the plate scrapes the paint around the hole. I've the patch bay and IEC modules (which Temple Boards in the UK kindly mounted for me pre-delivery) and never had any problems with them. All in all, no complaints here.
 
Messages
2
I switched to Temple boards a couple of years ago. For the most part, I have been very happy with the design of the boards. My persistent issue is that the adhesive backing for some of the plates comes undone over time - and I'm not sure why that would happen. I think that maybe I purchased a bad batch of plates, which may be the case as I have 4 Temple boards and hence a lot of plates and the last board I put together with parts purchased during 2020 is the one that has suffered the most loss of adhesion. Not sure what to do about that issue as I have also experienced the difficulty of removing the plates from other pedals when i was selling them, making this whole topic/issue more difficult to solve.
 

John Price

Silver Supporting Member
Messages
723
I couldn't stand those mounting plates. And if you try to move your pedals around you better hope they line up in the proper holes. If you have something mounted underneath you can't mount a plate in that area because of the mounting screw. I started to use velcro after awhile, but I just got rid of the board entirely. I also had major issues with the connection boxes they were supplying.

 






Trending Topics

Top Bottom