RE-20 Space Echo

burythemisery

Member
Messages
156
any of your guys' space echo every just "restart" itself after setting the tap tempo? why does it do this if so? do I need to use a different method of power supply?
 

AXXA

Silver Supporting Member
Messages
7,097
What kind of power are you using?

Mine works as I expect, using tap tempo or whatever else I do with it.
 

champion ruby

Member
Messages
1,805
Yes.

Likely because you are tapping too slow for the mode you are using. Might want to switch to long mode. If I'm wrong I guess our pedals are broken? I have 2 and they both do that.
 

burythemisery

Member
Messages
156
I have it powered using a 1spot daisy chain and I've also powered it individually before too and it does that. also its REALLY noisey in my pedal chain when it isn't engaged.
 

champion ruby

Member
Messages
1,805
I have it powered using a 1spot daisy chain and I've also powered it individually before too and it does that. also its REALLY noisey in my pedal chain when it isn't engaged.
The tap tempo issue is not power related. The noise is power related and the 1spot does not jive with this pedal.
 

AXXA

Silver Supporting Member
Messages
7,097
I have noticed the noise issue, and I'm powering it with a PP2+. It is noisier when off than it is when on (surprisingly), but it is pretty noisy either way, and the noise correlates with the pulsing of the 'tape speed' LED. The noise doesn't really bother me through a clean amp, but with a dirtier amp it gets pretty bad. I freaking love the RE-20 though! VB-2 is super noisy also, but I don't really care. Both on the same board too ha ha!
 

wildschwein

Member
Messages
4,022
I run my RE-20 in my loop and have always just given it it's own power supply which is just a 1200ma 9v adapter - no noise at all. I think I tried daisy chaining it when I first got it and probably had that tape speed noise hence the reason I gave it it's own supply. I run about 8 others pedals on my board off just one other 2000ma 9v adapter.
 

JackJordan

Member
Messages
1,357
Mine was noisy and I used both a 1spot and a Boss wall wart.

I always loved picking this pedal up just so that I could trade it... I don't know why, but I always got the best trade offers when trying to sell these.

I think people want to give it a shot, but don't want to dish out the dough as they are a little pricey. Its not your common delay, and a little bit of a niche so people aren't sure if it will float their boat or not.
 

wildschwein

Member
Messages
4,022
Yeah it's kind of dark and moody sort of delay - very unlike a lot of others I've tried. It does have a tapey sort of vibe though. I usually just set it on number 4 and leave it there. The spaceship landing noise is cool too.
 




Trending Topics

Top