Red Witch Moon Phaser question

Discussion in 'Effects, Pedals, Strings & Things' started by Ed Reed, Jun 14, 2008.

  1. Ed Reed

    Ed Reed Senior Member

    Messages:
    7,522
    Joined:
    Feb 21, 2004
    Location:
    Somewhere out on that horizon
    Mine pops like crazy when I turn it on. Is this normal? I'm not talking about the small pop a true bypass pedal has, this thing pops loud.
     
  2. Rob Eadgbe

    Rob Eadgbe Member

    Messages:
    438
    Joined:
    Oct 2, 2005
    Location:
    Greater Vancouver B.C.
    Mine did when I had it after all my gain pedals and a TC SCF, but when I moved it to the front of the signal chain, the pop was way less of an issue.
     
  3. zygoat

    zygoat Supporting Member

    Messages:
    857
    Joined:
    Oct 29, 2007
    Location:
    California
    Never had that problem with mine.
     
  4. Dexter.Sinister

    Dexter.Sinister Still breathing Gold Supporting Member

    Messages:
    5,640
    Joined:
    Feb 24, 2008
    Location:
    South Florida
  5. Ed Reed

    Ed Reed Senior Member

    Messages:
    7,522
    Joined:
    Feb 21, 2004
    Location:
    Somewhere out on that horizon
    Mine is before all OD's. Maybe a bad switch?
     
  6. Ben C.

    Ben C. Member

    Messages:
    6,868
    Joined:
    Jul 21, 2005
    Location:
    New England
    No. Mine popped like some TB pedals do, and it's not unusual.
    Mine (Dlx. Moon Phase) was 3rd in line when it popped ... Morley BH2 -> BJF PGC -> Red Witch -> etc. etc.
    So the chain was a buffered pedal (BH2), followed by a TB pedal (PGC), and then a TB pedal (Moon Phase).

    Then I picked up a Sobbat PB-2 which is totally awesome in its own phasey way - more like a traditional phaser where I feel the Moon is more like a Vibe in the spectrum of phasing. The PB-2 is buffered. And I put the Moon Phase after it, so the chain now goes:

    Morley BH2 -> BJF PGC -> Sobbat PB-2 -> Red Witch -> etc. etc.

    And now there's no pop.

    -Ben
     
  7. Ed Reed

    Ed Reed Senior Member

    Messages:
    7,522
    Joined:
    Feb 21, 2004
    Location:
    Somewhere out on that horizon
    Bruno over on HRI suggested turning it on and off at least 10 times in a row. That did it, no pops now. I had even tried switching about 3 or 4 times but it needed more.
     
  8. Ben C.

    Ben C. Member

    Messages:
    6,868
    Joined:
    Jul 21, 2005
    Location:
    New England
    Yes, now try it tomorrow. And it will pop.
    But yes, that's a workaround for any popping TB pedal... whenever you 'start the board up', turn those switches on and off a few times on the poppers... they'll be ok for the rest of the eve. usually.
     
  9. dividedsky

    dividedsky Member

    Messages:
    4,141
    Joined:
    Oct 13, 2005
    Location:
    The Acoustic Guitar Forum
    Had a couple of them, never noticed it.
     
  10. codyj84

    codyj84 Member

    Messages:
    1,508
    Joined:
    Oct 3, 2007
    Location:
    Tulsa, OK
    MIne pops really loud as well. I think its inherit of TB pedals. If you click it on n off a few times before you power the amp or in rehearsal that does the trick.
     
  11. BluePowder

    BluePowder Member

    Messages:
    1,106
    Joined:
    Jul 21, 2005
    Location:
    Singapore
    Mine used to pop the first time being switched on, after that for the rest of the gig no problems whatsoever.

    Strange though, I've had it for maybe 2 years now, absolutely no more popping.
     
  12. dobro man

    dobro man Member

    Messages:
    155
    Joined:
    Mar 8, 2008
    Location:
    Bangkok, Outer Space
    Mine never does that neither....
     
  13. Dexter.Sinister

    Dexter.Sinister Still breathing Gold Supporting Member

    Messages:
    5,640
    Joined:
    Feb 24, 2008
    Location:
    South Florida
    Well then install a bleeder from the input to ground through a cap.

    DS
     
  14. ducmike

    ducmike Silver Supporting Member

    Messages:
    1,681
    Joined:
    Jul 25, 2004
    Location:
    Dallas, TX
    I had this problem when I first got mine a few years ago. Ben sent me a diagram to solder a wire across a couple of the post on the footswitch. He offered to do it himself, but with shipping time, and customs to New Zealand, I did it my self. Email Ben for the diagram.
     

Share This Page