Reverb tank for Bill M Blues Junior 2x10

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by paulybeast43, Jan 2, 2018.

  1. paulybeast43

    paulybeast43 Member

    Messages:
    29
    Joined:
    Jan 29, 2013
    Location:
    Omaha, NE
    Came across a 2010 BJ in a trade and had a local tech do Bill M mods, plus new TO20 output transformer. Then decided to upgrade the cab to a Mojotone Super 2x10 w/ Tone Tubby HBomb.

    I ordered a PRMOD- 8EB2C1B reverb tank and when I installed it there was some crackling or static-like sound that would only happen when the reverb was turned up.

    I'm not tech savvy when it comes to amps, but I've installed reverb tanks and new speakers in the past. Didn't want to sent it out to a tech if I could fix it at home.

    Anybody know what I'm doing wrong? My thoughts are 1) either I ordered the wrong tank, or 2) the tank I order isn't designed for a 2x10 and I need something larger.

    I've included pics of the stock Accutronics tank in the 1x12 and the one I ordered.
    Many thanks for any input/assistance.
     
  2. jay42

    jay42 Member

    Messages:
    6,800
    Joined:
    Dec 20, 2006
    Location:
    Sandy Eggo
    1) does wiggling the reverb cables make a difference?
    2) if you connect the old tank, what happens?

    The think is op amp driven, so the actual tank model shouldn't make a whole lot of difference...don't have more time to look into it. I assume the tank vendor said it would work.
     
  3. Jeff Gehring

    Jeff Gehring Silver Supporting Member

    Messages:
    4,184
    Joined:
    Jan 17, 2008
    Location:
    Kansas City area
    The tank you ordered is the correct one for the amp as stated in the Fender service manual for the Blues Junior.
     

Share This Page