RP360 newbie - fizz question

Wildwind

Member
Messages
1,718
Just got it as a home practice unit and occasional very small gig processor.

First problem I'm hoping someone can help me with - high-gain sounds are FIZZY! The Mesa IIC is the best of them and is quite good, but the rest (Marshalls mainly) are not fun to play.

I'm sure there is a fix, some trick I don't know. Any advice?
 

Wildwind

Member
Messages
1,718
I just moved and my mixer isn't set up yet. So it's being plugged directly into my Mackie DLM8. No other gear of any kind. I'll get the mixer set up this weekend probably. Good question, though.

I have long experience with modelers. Fizz was a part of the equation some years back (before I went over to the dark side) and there were ways to minimize it. But this is just nasty. Even the Mesa is doing it. So I'm sure I am doing something wrong or less than ideal and have not had the time to troubleshoot this.

Thanks!
 

burningyen

Member
Messages
15,368
The RP360 has an internal Amp/Mixer setting, that's what I was asking about. The setting determines how bright/harsh the sound is.
 

Lele

Member
Messages
1,942
Burningyen is right, and the first thing you should check is if the (software) switch is on AMP or Mixer.
You should select AMP if you use your RP360 in front of a guitar amp or with a separate IR convolver, because the "AMP" choice will not filter the high frequencies.
In all the other cases, like yours if I understand well, you should select MIXER.

No, you can't select the "MIXER" switch via Nexus. BUT if you use your RP360 when it is connected to a PC via Nexus, it will switch automatically to the "Mixer" output choice (and you can't change it).
On the contrary, when it is not connected to USB (or to headphones) you should select the "Mixer" output on the RP360 itself (just press the "system" button, till you get the "output to" choice).

EDIT: it's not 100% right what I wrote earlier! The "Mixer" selection is automatic only if you connect only the headphones, BUT if you connect also a jack to the output THEN you have to select also the AMP or MIXER choice by hand on the RP360!

As I wrote in another very recent thread, in my opinion the RP360 does not cut enough high frequencies (unlike other more expensive modelers using separate IR cab+mic sim files), so what you call fizzy tones could be due to that, specially at medium/high volume.
My suggestion (and in my case it works very well) is to use the RP360 "4x12 Recto cab" with any amp sim and to enable the eq effect, placing it post amp, with the following settings:
lows: -12dB, 71Hz, wide bandwidth
(if it kills too much lows in your case, you could reduce the bandwidth, and/or decrease the band frequency, or cut a little less than 12dB)
mids: +1dB, 3kHz, narrow bandwidth
(imho this helps to restore some clarity that will be killed by the next treble setting)
highs: -10dB, 6.70kHz, medium bandwidth
(if it kills too much highs, you could increase the frequency or cut a little less than 10dB)
and you'll get a lot of punch with no fizz.
 
Last edited:

Wildwind

Member
Messages
1,718
What a difference!!! Many many thanks! High-gain tones are now rocking hard! And I haven't even tried Lele's tips, which I will. I copied them onto my desktop for when I have more time. But it sounds great already and will certainly get the job done.
 




Trending Topics

Top Bottom