SKB PS45 power problem?

Discussion in 'Effects, Pedals, Strings & Things' started by mrt, Jan 2, 2008.


  1. mrt

    mrt Member

    Messages:
    520
    Joined:
    May 12, 2007
    I have the SKB PS45 powered pedal board.. The 9v inputs stopped working????

    the 3 grounded plugs still work fine.

    I didn't use it for about 8 months because I was using rack gear, but it worked fine back then, I got some new pedals and nothing work with the 9v inputs? I tried different cables.. It just seems there is no power going to that part of the board....

    Any idea what I should do? or what would cause this?

    Thanks.
     
  2. semihollow

    semihollow Member

    Messages:
    109
    Joined:
    Mar 15, 2007
    Location:
    SoCal
    You might give SKB a try. They have decent warranties and have come through for me in the past. Good Luck.
     
  3. mrt

    mrt Member

    Messages:
    520
    Joined:
    May 12, 2007
    I'd hate to ship this thing back$$ I've had it for over a year maybe 2? I'm sure the warranty is up...

    I just dont get why ONLY the 9 volt inputs stopped working and not the 3 grounded plugs? I guess I would think it all would stop working:confused:

    Thanks
     
  4. stinkfoot

    stinkfoot Member

    Messages:
    5,894
    Joined:
    Jun 20, 2004
    Location:
    Uppsala, Sweden
    It sounds like something is shorting out the 9vDC outputs. Did this happen when you added the new pedals? If so, one of them might be positive ground (ge fuzz or similar), which would definitely short the power out. What pedal(s) did you add?

    Try removing the power cables from the pedals one by one, and see if the power comes back when you disconnect a particular pedal. If so, you've found the offender :D

    /Andreas
     
  5. mrt

    mrt Member

    Messages:
    520
    Joined:
    May 12, 2007
    No, there was nothing plugged into the board. I just plugged in 1 pedal, and tried a few different ones and 5 different cables, and nothing?
     

Share This Page