Sparkle Drive 9v in not working

Discussion in 'Effects, Pedals, Strings & Things' started by bluesking55, Feb 13, 2012.

  1. bluesking55

    bluesking55 Supporting Member

    Messages:
    1,431
    Joined:
    Dec 8, 2008
    Location:
    richmond,va
    Bought this from someone here and the guy didnt tell me the 9v power input is inop.. Of all the million pedals I bought. this is the only 1.
    Is this a normal thing with these? Hard to fix?
     
  2. dbx

    dbx Member

    Messages:
    2,715
    Joined:
    Jan 21, 2005
    Location:
    En casa, EL A
    Sometimes it's just the soldered connections are broken from the battery snap. Trace the wires back from the battery snap and see if something looks suspicious along the way. Also check the wiring from the input jack along the way to the circuit board. It works ok using the AC tap?

    :cool:
     
  3. tdk8709

    tdk8709 Senior Member

    Messages:
    961
    Joined:
    Jun 2, 2011
    Location:
    Southern Illinois
    Return it and get your money back.
     
  4. bluesking55

    bluesking55 Supporting Member

    Messages:
    1,431
    Joined:
    Dec 8, 2008
    Location:
    richmond,va
    It works well with a battery but using a power supply, one spot or the 1 on my powered skb board, it doesnt work.
    Cant return it forgot who i bought it from and Ive had it 3 months now and never used the power input
     
  5. dbx

    dbx Member

    Messages:
    2,715
    Joined:
    Jan 21, 2005
    Location:
    En casa, EL A
    Drag...OK, look at the wires from the AC tap to the board...good luck with it...
     
  6. bluesking55

    bluesking55 Supporting Member

    Messages:
    1,431
    Joined:
    Dec 8, 2008
    Location:
    richmond,va
    Voodoo Labs is gonna fix it for free, got the email this moring
    They got a 5 year warrenty
     

Share This Page