Speaker mounting - Help Needed

Discussion in 'Amps and Cabs' started by Little Robert, Feb 13, 2008.


  1. Little Robert

    Little Robert Member

    Messages:
    368
    Joined:
    Dec 2, 2006
    Location:
    Monterey Bay, CA
    Hi,I have an avatar 1x12 with a G12H30 - front loaded.

    I while ago I swapped a grennback in there for a day to see what it would sound like.

    When I put the G12H30 back in, I think I over tightened it. It's become harsh sounding. I took the speaker out, rotated it when putting it back in - not as tightly screwed in.

    There's still some harshness/brittleness and am wondering if the foam stuff that's mounted on the speaker rim and acts as kind of a gasket between the baffle and the rim of the speaker should be replaced with cork or something else. It's all flattened/compressed and probably not doing what it was meant to do.

    I have played my amp through a borrowed cabinet and checked all cables and connections and the harshness is not coming from those

    Anyone have any thoughts?


    Many thanks,
    Bob
     
  2. Little Robert

    Little Robert Member

    Messages:
    368
    Joined:
    Dec 2, 2006
    Location:
    Monterey Bay, CA
  3. Ray

    Ray Member

    Messages:
    163
    Joined:
    Nov 20, 2005
    Location:
    Buffalo
    I don't think the mounting screws would change the sound of the speaker, must be something else, but I don't know what. Check the polarity of the speaker wires just to be sure you have them on the right terminals.
     
  4. rockon1

    rockon1 Member

    Messages:
    11,456
    Joined:
    Aug 12, 2005
    Location:
    Stamford CT
  5. Little Robert

    Little Robert Member

    Messages:
    368
    Joined:
    Dec 2, 2006
    Location:
    Monterey Bay, CA

Share This Page