Strymon El Capistan & Pettyjohn Predrive

Discussion in 'Effects, Pedals, Strings & Things' started by Melldo, Apr 27, 2016.

  1. Melldo

    Melldo Member

    Messages:
    416
    Joined:
    Jul 26, 2013
    Location:
    Glasgow, Scotland
    So I have a Pettyjohn Predrive and am about to pull the trigger on an El Cap. Only thing is I've read that Strymon pedals can hum a bit with high voltage pedals in front of them. The Predrive is powered on 18V, am I likely to experience problems? Anyone here use both already?
     
  2. Zack.LW

    Zack.LW Member

    Messages:
    1,162
    Joined:
    Mar 30, 2016
    I don't know if it's the same concept but I have a jhs superbolt that converts 9V to 18V and have two strymon pedals downstream. No problems with it at all.
     
  3. Judas68fr

    Judas68fr Member

    Messages:
    1,141
    Joined:
    Jan 24, 2014
    I have an 18V volt Wampler Pinnacle in front of a Strymon Flint and no hum.
     
  4. minty901

    minty901 Member

    Messages:
    2,125
    Joined:
    Nov 4, 2014
    It only happens if the pedal internally increases the voltage with a charge pump. If your pedal simply accepts a high voltage at input then it should be fine. Also the problems have mostly only been reported for the big box pedals like Timeline and Mobius (though it could occur on others).
     
  5. Stephen Pettyjohn

    Stephen Pettyjohn Member

    Messages:
    230
    Joined:
    Sep 24, 2014
    Location:
    Oregon
    The PreDrive doesnt have a charge pump, should be fine!
     
  6. jsytsma

    jsytsma Member

    Messages:
    1,957
    Joined:
    Aug 27, 2011
    Location:
    Guelph, Ontario
    I'm running two 18V pedals in front of my Strymon pedals with no issue. Should be fine
     
  7. S. F. Sorrow

    S. F. Sorrow Member

    Messages:
    6,846
    Joined:
    Nov 6, 2012
    Location:
    South of Mars
    I've used full voltage tube pedals (Effectrode Blackbird & EHX English Muff'n) running in front and it's quiet. They run on big 12v wall worts.
     
  8. 7thString

    7thString Member

    Messages:
    1,079
    Joined:
    Feb 14, 2014
    Location:
    Perth, WA
    Its the charge pump that causes issues. (ie 9v supply, 18v internal headroom) Pedals powered with an 18v external supply shouldn't be a problem, and usually only an issue with klons and klones placed right before a timeline or mobius IIRC
     
  9. jmontgomery

    jmontgomery Supporting Member

    Messages:
    2,217
    Joined:
    Aug 13, 2006
    Location:
    Arbuckle Country
    What about a klone in front of the amp and a Timeline or Mobius in the amps loop?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice