Taylor ES misery

Discussion in 'Acoustic Instruments' started by chris77, Aug 27, 2008.

  1. chris77

    chris77 Member

    Messages:
    244
    Joined:
    Sep 4, 2006
    Well it is offical I hate my ES system. I have a 410 ce L3 with the ES system. I have fought it and fought it trying to get the honk out. I play through a LR Baggs Pari DI to the snake(no amp) and still can not dial it in. Well before giving up I tried one last thing. I bought a MXR 10 ban EQ and WOW I finally got it. Defined lows crispy highs and no more Mid-Mud. I have been playing elixer polys for years and love the guitar unplugged just never could get the unplugged tone out of it plugged in. the mxr does not kill my gas for a d-28 but it should keep me from selling it out right for some stupid low amount a money. Anybody dealing with the same problem with the ES system. Also anybody sucked it up and drilled a new hole in the body for a different pickup system?

    Shawn
     
  2. waxnsteel

    waxnsteel Member

    Messages:
    3,131
    Joined:
    May 14, 2005
    No EQ can fix that sound. Once you start playing above the 4th fret, it's all magnetic pickup tone, and neck tone.
     
  3. walterw

    walterw Gold Supporting Member

    Messages:
    33,556
    Joined:
    Oct 16, 2006
    a real parametric will allow you to scoop out that electric-y midrange, but yeah, i wish they came with an option to turn down the magnetic neck pickup.
     
  4. The Pup

    The Pup Supporting Member

    Messages:
    2,722
    Joined:
    Nov 5, 2005
    I much prefer the older prefix system to the ES scourge.
     
  5. Macman

    Macman Member

    Messages:
    81
    Joined:
    Apr 7, 2007
    You might wanna bring in your taylor to the nearest certified service center. What you have there might be the version 1 of the ES systems. They did some modifications from what the local boys here in Singapore told me. Some have had that preamp replaced ( or was it a cable?) and it solved the problem.

    But seriously, i've never been a fan of the ES. Have a 912C that I put a Baggs RT2 in. Couldn't be happier.
     
  6. franksguitar

    franksguitar Member

    Messages:
    3,692
    Joined:
    Dec 6, 2006
    Location:
    Fairfield, CT
    I had version 1 ES in my 2003 814CE. I went to a Taylor event at the local store where the techs were there. They gutted my old system entirely including the battery compartment which I thought my original system sounded like crap and said so, and the Taylor tech said alot of the contacts dried out and may have been installed incorrectly out of phase and they improved them, and they put in the new improved ES system with anti feedback and the guitar sounds like night and day, fantastic! Also use the low impedence Taylor cable.
     

Share This Page