TC Electronics Tone Print switch issue resolved?

Discussion in 'Effects, Pedals, Strings & Things' started by Blueshound, Mar 22, 2015.

  1. Blueshound

    Blueshound Member

    Messages:
    347
    Joined:
    Mar 29, 2005
    Location:
    Central Wisconsin
    I really like their HOF and Flashback pedals but am a little concerned regarding the posts stating that, at least at one point, there were either QC issues or a design flaw with the switches they were using. Most of the posts appear to be older ones, which would seem to indicate the issue has been resolved, but I could not find anything definitive stating the issue has been fixed.

    Lee
     
  2. coltonius

    coltonius Señor Member Silver Supporting Member

    Messages:
    10,060
    Joined:
    May 21, 2013
    Location:
    Wacko
  3. coltonius

    coltonius Señor Member Silver Supporting Member

    Messages:
    10,060
    Joined:
    May 21, 2013
    Location:
    Wacko
    You're not SOL. They're replacable (in the X4 and standard TP pedals, anyway).
     
  4. coltonius

    coltonius Señor Member Silver Supporting Member

    Messages:
    10,060
    Joined:
    May 21, 2013
    Location:
    Wacko
    Good luck? I've done it before. It took 5 minutes. ;)
     
  5. ejoco

    ejoco Member

    Messages:
    610
    Joined:
    Dec 11, 2013
    Location:
    Dallas, Texas
    Yes the switches are horrible and always break and the buffers on boss pedals ruin you tone and the pots on EHX pedals fail after 2 weeks....actually I've owned 5 TC pedals and have had 0 issues with the switches...
     
  6. Blueshound

    Blueshound Member

    Messages:
    347
    Joined:
    Mar 29, 2005
    Location:
    Central Wisconsin
  7. lux_interior

    lux_interior Member

    Messages:
    5,387
    Joined:
    Aug 5, 2008
    Location:
    Somewhere between heaven and hell
    Same here, and all of them early (actually among the first) batches with supposedly "bad" switches. Used and abused at home, rehearals and gigs for years.
     
  8. William Braddell

    William Braddell Member

    Messages:
    2,819
    Joined:
    Sep 28, 2012
    Location:
    New Zealand
    I bought my Ditto last year. Switch stopped working really fast. It was pretty disappointing.
     

Share This Page