TC pedals still have issues ?

Discussion in 'Effects, Pedals, Strings & Things' started by CA$H FLOW, Feb 18, 2012.

  1. CA$H FLOW

    CA$H FLOW Member

    Messages:
    927
    Joined:
    Dec 10, 2011
    Been reading lots about the Flashback and Hall Of Fame and I've read many posts about these pedals having issues. Sounded like the footswitch stops working or the pedal works intermittently.
    Have they worked out the kinks with these pedals yet? What are you're thoughts on em ?
     
  2. dshobe

    dshobe Rocky Mountain Way Silver Supporting Member

    Messages:
    4,139
    Joined:
    Oct 5, 2010
    Location:
    Mile High
    I've had the hof, have the fb now, never had any issues with either one.
     
  3. oxtone

    oxtone Member

    Messages:
    4,757
    Joined:
    Sep 14, 2005
    Location:
    Edina, MN
    No issue's with my Hall of Fame, ever.
     
  4. walkers

    walkers Member

    Messages:
    245
    Joined:
    Feb 11, 2010
    I had the HOF and it was intermittent at best, it just wouldn't work...I sent it back the same day. Others seem to have no problems at all, perhaps just a bad run?
     
  5. iama

    iama Member

    Messages:
    257
    Joined:
    May 5, 2007
    I'm experiencing an issue with my Flashback. Everything is functioning except that the Toneprint stopped transmitting to the pedal. The pedal doesn't flash when I try to send the Toneprint from my phone app. It was working great then just stopped.

    I have tried just about everything. I've re-installed the software update to the pedal. I unplugged the power and powered back up. I re-installed the Android app. I turned the guitar volume up. It stopped flashing green after I tried to transmit.

    Everything still works great and would be a great pedal without the Toneprint. I just want it to work. The next step is to contact customer support. I'm hoping that it is an easy fix. It's a great pedal otherwise.
     
  6. CA$H FLOW

    CA$H FLOW Member

    Messages:
    927
    Joined:
    Dec 10, 2011
    How long have you guys had these pedals ? I really don't want to fork out hard earned cash for faulty music products anymore. In all honesty I'm quite surprised by the number of companies putting out products with flaws and faults; and you know they were aware of the issue before said product shipped out.
     
  7. the fat one

    the fat one Senior Member

    Messages:
    1,501
    Joined:
    Sep 28, 2011
    I have not read that, and I've been in a lot of the Flashback threads and TonePrint threads and even started some of them because I have one.
     
  8. brain21

    brain21 Member

    Messages:
    2,371
    Joined:
    Oct 25, 2007
    Just curious, does it work with a PC? Just wondering if it is a pedal issue or Android software issue?
     
  9. Rage

    Rage Supporting Member

    Messages:
    463
    Joined:
    Dec 16, 2011
    Location:
    United Snakes
    I used to own a polytune. It only worked for half a day. It suddenly stopped tracking lower E and D.
     
  10. strombie

    strombie Member

    Messages:
    680
    Joined:
    Aug 7, 2011
    Location:
    Washington State
    polytune and flashback have worked flawlessly for me but I sent two HOF's back in one week because they both pooped out. which was... poopy.
     
  11. jamesie

    jamesie Member

    Messages:
    644
    Joined:
    Aug 5, 2007
    i use a few tc pedals - vintage delay about 5 years - predrive about 5 years and the latest is a nova system limited about 3 month - without anytroubles
     
  12. CA$H FLOW

    CA$H FLOW Member

    Messages:
    927
    Joined:
    Dec 10, 2011
    Yeah this kind of thing would be just my luck!
     
  13. the fat one

    the fat one Senior Member

    Messages:
    1,501
    Joined:
    Sep 28, 2011
    : (

    say it ain't so Joe.
     
  14. MG90

    MG90 Member

    Messages:
    1,512
    Joined:
    Jul 19, 2011
    My Polytune does not work when it shows all 6 strings at once. It only shows a few strings. Still works 1 string a a time.

    Not very well made. Bad manufacturing. TC sucks big...

    ...time.
     
  15. Waxhead

    Waxhead Member

    Messages:
    5,562
    Joined:
    Sep 9, 2007
    Location:
    Surfin at Merewether Point, NSW Australia

    right then - where are all these reports then - I've not seen any more -ve reports on TC products than the average with every brand. :huh
    Wanna see -ve build quality reports - check Line 6 hehe
     
  16. capt4inslow

    capt4inslow Member

    Messages:
    968
    Joined:
    Oct 17, 2009
    Location:
    inside
    Am I the only guy with perfectly working TC pedals???
     
  17. Daka3

    Daka3 Member

    Messages:
    1,824
    Joined:
    Apr 1, 2011
    Location:
    Copenhagen, Denmark
    No. Everything cool with my FB.
     
  18. hydroquebec

    hydroquebec Member

    Messages:
    1,594
    Joined:
    Feb 7, 2012
    Location:
    Montreal, Canada
    I've had the Corona for about a year now without any issues - probably 400+ clicks on it.

    I've also had the Flashback and Hall of Fame for about 2 months without any issues so far. Tons of clicks on both of those pedals so far. I really like those two in particular.
     
  19. The Interceptor

    The Interceptor Member

    Messages:
    2,375
    Joined:
    Feb 28, 2011
    Location:
    Perth, Western Australia
    I've got a Polytune and a Flashback, each must be more than a year old. No complaints with either of them.
     
  20. wrightdude

    wrightdude Supporting Member

    Messages:
    4,027
    Joined:
    Jan 3, 2007
    Location:
    FREDNECK MD USA
    FB works GREAT! would buy again!
     

Share This Page