• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

The Official Fender Mustang GTX Amp Thread (2020)

dazco

Member
Messages
15,486
I tried updating via wifi and no update is avaliable. Mine works with wifi, never had an issue. So if there is 3.0.87 available why isn't it avaliable via wifi.
 

FrankHarv

Member
Messages
194
Maybe to Fender it's not worth calling it a "firmware update". With 3.0.87 being loaded on new amps from stores the last few months, no one has identified any "change" associated with that new firmware number. Maybe Jason Stillwell can shed light on this, then again he may not have the latitude from Fender Corp to speak to this.
 

dazco

Member
Messages
15,486
Maybe to Fender it's not worth calling it a "firmware update". With 3.0.87 being loaded on new amps from stores the last few months, no one has identified any "change" associated with that new firmware number. Maybe Jason Stillwell can shed light on this, then again he may not have the latitude from Fender Corp to speak to this.
Thats basically what i was trying to say....that version comes in the newer GTX's and is the same as the latest in older ones, so older ones need to update via firmware because they changed something in the newest amps. Maybe the server address was changed and older GTX's won't be able to find firmware w/o USB updating to this new version that hold the new server addy. Something like that. If so this may be an indication they want everyone to do this because they will be releasing a true update soon/
 

dazco

Member
Messages
15,486
Ok, it worked and is now 3.0.87. Of course because my phone doesn't work with the app all my presets are gone. Thanks fender for the lack of a PC app to save them. At least i have my main patch by shooting pics of the LCD on every page of settings. Now lets see if this was to precede a real update.
 

dazco

Member
Messages
15,486
Still not seeing release notes on this firmware update anywhere?

Anybody find them?
I'm quite sure this isn't a regular update. Are u familiar with what i was saying about the GT USB update of a few years ago? To be clear, at some point the gt firmware could no longer be updated on amps that were older and not the latest from the factory. Something was changed at a given point in the firmware on new amps recently shipped and as i suggested in an above post, they may have change the server address for the updates. So if i am correct on that, new amps were shipped with the new update server address in their firmware and they could be updated as normal next time a update came out. But older amps had the OLD server address so the could not be updated via wifi. So fender released a harware update like this which could get formware with the new server address in it so they could then do wifi updates in the future. Now, thats just a guess on my part and it may not have been about the server address. But it may have been something in the same vein, so if thats the case this is really NOT a update as far as fixes and additions. It would be the same firmware as you have now in your older amp but for the server addy or some other thing that makes this necessary. As i said earlier, if it IS the same thing as that hardware update on the GT that would signal that we are likely to see a real update with fixes and new features soon. They would be doing this so that those of us with older amps will be ready to get the REAL update soon to arrive.....hopefully. (lord, let my theory be correct:) )
 

FrankHarv

Member
Messages
194
There are no release notes. And Fender's firmware info page has not been updated since the (still the current firmware) from May 2020.
 

jlagrassa

Silver Supporting Member
Messages
6,427
Mine came stock with 3.0.83 so a newer update than I have, I will wait for more info before I check it out!
 

KentEkl

Member
Messages
11
Updated to 3.0.87 and restored the settings and it worked fine.
Had to reconfigure wifi.
Version was 3.0.84 and the base version 3.0.52 now both at 3.0.87.
Probably only bug fixes since there are no release notes.
 

Dimitri F.

Member
Messages
262
Updated to 3.0.87 and restored the settings and it worked fine.
Had to reconfigure wifi.
Version was 3.0.84 and the base version 3.0.52 now both at 3.0.87.
Probably only bug fixes since there are no release notes.
Have you noticed if the problem of restoring your Preset order at random has finally been solved?
 

Dimitri F.

Member
Messages
262
Also for IOS.


3.1.6
Nov 10, 2021


Improvements:
Improved application performance.
Improved authorization panel.
New! Now you can sign up for a Fender account using your Gmail login.

Bugfixing:
Fixed issues related to building signal chain.
Fixed sync issues.
Fixed issues related to the replacement of the amp and effects.
Fixed connectivity issues.
Fixed UI issues.
Fixed other minor issues.

- (the underline is mine).
about updates and fixes :
i recently tried again the pitch shifter and the pitch parameter continues to be unmanageable by Fender Tone : as said it changes in a more consistent, reliable way just the octaves , particularly the extreme values of +2400 and -2400 cents, or also +1200 and -1200 cents, all the rest is pretty random, and usually, with rare exceptions, doesn't transmit the change of the value to the amp.

Apparently that is a kind of issues that require a firmware update to be fixed.
 
Last edited:

dazco

Member
Messages
15,486
I noticed my amps new version is not only listed and the curret version, but also the base version. So i think that pretty much solidifies what i said about newer amps coming with this base version and something in it makes it a base version. Probably as i suggested the server address but maybe something else i just can't think of. In any case thats what it was, definitionally not an update for fixes/new models. Server address is the only thing i can think of that makes sense because otherwise why they have made us use a hardware update instead of wifi?
 

timbuck2

Senior Member
Messages
3,044
Another update:

The GTX-100 has overall been really great. I've only noticed one thing at this point - a single popping sound every 5-10 minutes. It sounds similar to the pop that occurs when I connect the amp to the Fender Tone app via bluetooth. This happens whether I'm playing, or leaving the amp on while I take a practice break.

I don't think it's a cause for concern, but wanted to ask if anyone else has run into this.
thats why he sold it maybe
 




Top Bottom