Top Hat Emplexador

FAC

Member
Messages
939
There is a used Emplexador model T-35 E at my local GC. The control layout is different than the current model on the Top Hat website.

Any info on this version would be greatly appreciated. I have not been able to play it at this point.
 

Rod

Tone is Paramount
Gold Supporting Member
Messages
22,081
Put up a picture and we can give you the rundown.... Is the logo script lettering?
 

Teleplayer

Moder8er
Staff member
Messages
19,872
Like this??



If so, it's a script logo circuit. Incredibly "chewy" with tons of that open Marshall "Kerrrrrrrang". Killer amps.

Mine is one of the initial block logo head/cab boxes. The circuit was still pure script logo goodness.
 

tophatdad

Member
Messages
91
T-35 E sounds like it could be an Embassy. 2 channels and uses 4 6v6's in the power section. Like Rod said - put up a picture!

Best,
Mike
 

sickboy79

Member
Messages
13,069
FWIW - my 2001 Block Logo Emplexador head has T-35 on the back panel. My guess is it was either misprinted, or they used the wrong panel on mine. It's definitely an Emplexador.
 

FAC

Member
Messages
939
Thanks for the input!

If this is the one, looks to be a T35 (older King Royale?) in a newer shell:
http://www.guitarcenter.com/Used/TopHat/T35E-Emplexador-Tube-Guitar-Amp-Head.gc
That's the one...yes, the fact that it appears to have a cut knob was throwing me a bit. I'll see if I can peer through the back plate and see what the tubes look like.

FWIW - my 2001 Block Logo Emplexador head has T-35 on the back panel. My guess is it was either misprinted, or they used the wrong panel on mine. It's definitely an Emplexador.
Does yours have a cut knob?
 

Pedro58

Silver Supporting Member
Messages
5,864
Play it. It will undoubtedly kick major ass and then you won't care so much about the circuit. I'm only guessing.
 

FAC

Member
Messages
939
Went in to play it tonight...jewel light lit up, but no sound. The Top Hat logo did not light up. Checked everything I could think of...no sound. Then some dude walks up to me and says he bought the amp last week and returned it because when he got it home it did not work. Apparently they just put it right back on the floor.

The rear grill is substantial, so it is difficult to see the tubes, but they seemed taller than a typical 6V6 and clearly not EL84s...but the front layout is not like a typical Emplexador, as it has a cut knob, etc. As posted above, this is the amp:

http://www.guitarcenter.com/Used/TopHat/T35E-Emplexador-Tube-Guitar-Amp-Head.gc
 

stratotastic

Member
Messages
7,241
Went in to play it tonight...jewel light lit up, but no sound. The Top Hat logo did not light up. Checked everything I could think of...no sound. Then some dude walks up to me and says he bought the amp last week and returned it because when he got it home it did not work. Apparently they just put it right back on the floor.
:facepalm Guitar Center never fails to fail.
 

Rod

Tone is Paramount
Gold Supporting Member
Messages
22,081
That's a King Royale front panel layout/// Offer them $400 then send it to Brian at Top Hat to get fixed
 

sickboy79

Member
Messages
13,069
Thanks for the input!



That's the one...yes, the fact that it appears to have a cut knob was throwing me a bit. I'll see if I can peer through the back plate and see what the tubes look like.



Does yours have a cut knob?
Mine does not. It's definitely an Emplexador.
 

rawkguitarist

Member
Messages
11,014
Yeah man... try to get a major discount and then send it to Brian for an overhaul. Brian will not disappoint – he makes some of the best amps on the planet. Maybe even call him first and see what he says about the particular amp. You will be entertained with his crazy in depth knowledge about tube amp design.
 
Messages
47
I called them. I guess they got it checked out. Was just bad tubes. 6v6s quad and new JJS throughout the pre. Sounds like a dream, quiet as could be with no negative feedback I can find. Killer, Killer amp. So versatile.
 
Last edited:

Blunder

Silver Supporting Member
Messages
1,223
Nice score. Embassy's are sweet amps and somewhat rare. I've got a 6V6 Emplexador40 and it is a great amp.

Some of the best built amps out there. I've never had any issues with any of my TopHats.
 




Trending Topics

Top