TR CRS and G System - WTF!

Discussion in 'Amps and Cabs' started by RobertMiller, Mar 2, 2006.


  1. RobertMiller

    RobertMiller Member

    Messages:
    1,330
    Joined:
    Jul 8, 2004
    Location:
    Baton Rouge, LA
    It seems that the G System won't work properly in the loop of my Two Rock CR Sig. Anyone else having this problem? It works just fine in front of the amp (guitar into inst input on the G sys, G sys power out into the amp's input).
     
  2. guittarzzan

    guittarzzan Member

    Messages:
    62
    Joined:
    Oct 18, 2005
    You'll want to run your amp in the loop and not in front of the g system. That way you can take advantage of the loops and other effects that go before the amp. It should work either way, but you'll lose a lot of what makes the g system cool by running it entirely through your effects loop.
     
  3. p.snail

    p.snail Supporting Member

    Messages:
    786
    Joined:
    Aug 6, 2003
    Location:
    Union, Ky
    How do you have it hooked up? I would think you would want to input the amp's preamp through the preamp loop on the G system. You may already know this, but the way I would hook it up is Guitar> Input of G system> G system loop 5 send> Amp input> Amp Send> G system loop 5 return> output of G system> Amp return. I don't own either piece, but in my experience with other digital gear you have to crank down the presets as well. If you come back in through the loop too hot then you get this really nasty digital hash. It's simply overloading the signal. I hope this was at all helpful. I envy your gear dude. Two Rocks are awesome. Good luck.
     
  4. RobertMiller

    RobertMiller Member

    Messages:
    1,330
    Joined:
    Jul 8, 2004
    Location:
    Baton Rouge, LA
    That's the way I hooked it up, but this resulted in the master volumes on the amp not working, and also defeated the channel switching on the amp. I was also surprised to learn that it didn't work properly with the guitar into the amp, and the G sys isolated in the loop in a simple send/return configuration. It would be nice to have it in the loop, but ultimately I might just have to run it in front.
     
  5. p.snail

    p.snail Supporting Member

    Messages:
    786
    Joined:
    Aug 6, 2003
    Location:
    Union, Ky
    That's really bizaare. You may have to go in and activate loop 5 in each preset. If the G system is seeing the preamp only in loop 5 and it is disengaged then, it would bypass the entire front end of your amp. The signal would pass right by your preamp and would only be coming through the power section of your TR. That would explain why both you Master Volume and Channel switching isn't working.
     
  6. RobertMiller

    RobertMiller Member

    Messages:
    1,330
    Joined:
    Jul 8, 2004
    Location:
    Baton Rouge, LA
    I'll try it and report back. I wasn't even aware that there was a loop 5 to activate. Hopefully this can be done as a global and not in each and every freaking preset, but we'll see. Appreciate it, dood!
     
  7. p.snail

    p.snail Supporting Member

    Messages:
    786
    Joined:
    Aug 6, 2003
    Location:
    Union, Ky
    My understanding when I saw the demo was that the Loop 5 was the preamp loop. You could insert upto 4 external effects and a fifth loop just for preamps. I could be mistaken. Whatever loop you would use to insert the preamp is what I mean by Loop 5. Sorry if that was confusing.
     
  8. robbieboyette

    robbieboyette Member

    Messages:
    224
    Joined:
    Jan 15, 2006
    Location:
    South Carolina
    Yes it can be set up globally. I'm using mine with my Bogner Ecstasy Classic and I use the "Guitar> Input of G system> G system loop 5 send> Amp input> Amp Send> G system loop 5 return> output of G system> Amp return" set up that p snail described.
    It works fantastically.
    I owned a G Force and G Major prior to the G System so it only took me about 3 hours to set the G System up and set up the patches I wanted. If you are unfamiliar with TC Electronic rack gear it may take you a day or two to sit with it and go through the owners manual until you figure it out. But once you get it right...you'll love it.
     
  9. RobertMiller

    RobertMiller Member

    Messages:
    1,330
    Joined:
    Jul 8, 2004
    Location:
    Baton Rouge, LA
    I've got the "Insert lock" option in the "on" position in the utilities menu, so I'm assuming that it's on in all presets. Still the same deal. But I'll keep trouble shooting.
     
  10. RobertMiller

    RobertMiller Member

    Messages:
    1,330
    Joined:
    Jul 8, 2004
    Location:
    Baton Rouge, LA
    Well fellas, it's working. While I thought I had the insert loop locked, it apparently wasn't. Fired it up this morning, locked it, worked like a charm. :AOK
     
  11. p.snail

    p.snail Supporting Member

    Messages:
    786
    Joined:
    Aug 6, 2003
    Location:
    Union, Ky
    I'll bet it sounds incredible. Two Rocks are the shiz and TC makes killer effects. Color me green. good luck with it.
     

Share This Page