Tube Sockets - Suggestions Please

Discussion in 'Amps and Cabs' started by micstew, Feb 19, 2012.

  1. micstew

    micstew Member

    Messages:
    32
    Joined:
    Sep 22, 2009
    Location:
    Pleasanton, Ca
    Bought some Belton replacement tube sockets from the Tube Depot a few weeks ago to fix some static issues in my 1996 Blues Deluxe (I could induce the exact static sound by very slightly wiggling the power tubes in the sockets so I'm pretty sure that was the culprit - and yes cleaning helped but never completely resolved the issue). Problem is the mounting brackets on the replacement sockets are not quite aligned with the pins. No kidding. Apparently some super quality control over there at the Belton factory...:bonk

    Anyway, back to square one, so if anyone has suggestions on replacement power tube sockets, please lemme know. Price is not a concern (within reason) here - I'd much rather spend more and get a better product in this case.

    Photo: Belton 8 Pin Octal PC Mount Socket - 20.5mm Pins
    [​IMG]
     
  2. wi3465

    wi3465 Guitar Slut Gold Supporting Member

    Messages:
    586
    Joined:
    Sep 1, 2011
    Location:
    Atlanta,Georgia
    Google: amp maintenance. Do not recall the site, but someone on line was using a jewelers screwdrive inside the tube socket for the individual pins to tighten up the retainers. Please post what you find and good luck! Bill
     
  3. micstew

    micstew Member

    Messages:
    32
    Joined:
    Sep 22, 2009
    Location:
    Pleasanton, Ca
    Yep, tried that. BillM recommends it. Didn't work in this case. Original sockets now already removed. Alternate replacement suggestions needed.
     
  4. 3th3r

    3th3r Member

    Messages:
    1,238
    Joined:
    Dec 9, 2006
    Location:
    Los Angeles
    The original socket or bracket was likely not Belton. Have you tried different brand sockets?
    Or what about redrilling/enlarging the holes in the bracket?
     
  5. micstew

    micstew Member

    Messages:
    32
    Joined:
    Sep 22, 2009
    Location:
    Pleasanton, Ca
    Originals were not Beltons. This is not a problem of brand, it is an issue of sloppy alignment of the two parts of the Belton replacement sockets. I will of course alter the mounting holes of the Beltons if it comes to it, but sheesh, it really should not.
     
  6. micstew

    micstew Member

    Messages:
    32
    Joined:
    Sep 22, 2009
    Location:
    Pleasanton, Ca
    < Question deleted >
     
    Last edited: Feb 20, 2012

Share This Page