Tubemeister 18 - HELP

gvo369

Member
Messages
14
My Tubemeister 18 broke yesterday afternoon after only 4 months of ownership (purchased brand new).

The volume is suddenly extremely low even when cranked all the way up and put on the 18 watt power soak position. (My cell phone speaker is louder than the amp now, just to give an idea). And turning volume down all the way makes it louder than when fully turned up.

Does this sound like a tube issue? Repair guy over the phone said its most likely not.

Basically I need an outside opinion, should I get it repaired and sell it for a more "reliable" amp?

Any input is appreciated..

I like the tone, even for metal which is what I mostly play. I hope I didn't purchase a nice neon sign instead of a real guitar amp.
 
Last edited:

ledzep618

Member
Messages
5,175
I would say it's almost certainly s tube issue and I'd look for a new repair guy. Sound dropping out like that is a classic tube issue. Sequentially test each tube with a tube you know works. I'd bet either V1 preamp or power tubes. Especially power tubes if you're normally cranking it and attenuating.

If it's just a tube then whatever that's just maintenance, it's more a reflection of modern tube production than the amp itself.
 

gvo369

Member
Messages
14
I would say it's almost certainly s tube issue and I'd look for a new repair guy. Sound dropping out like that is a classic tube issue. Sequentially test each tube with a tube you know works. I'd bet either V1 preamp or power tubes. Especially power tubes if you're normally cranking it and attenuating.

If it's just a tube then whatever that's just maintenance, it's more a reflection of modern tube production than the amp itself.

Thats a little comforting, I will order a replacement set of tubes and test them out. Might be a good idea to change them all out anyways.

So if it turns out not to be the tubes, could there be a problem with the circuitry in that case?
 

gvo369

Member
Messages
14
H&K warranty for products purchased new from an authorized dealer in NA is absolutely valid. Their NA distributor is Yorkville. Call them directly.

Excellent idea thank you, I called them and there is a two year warranty directly through Yorkville. Was going to swap the tubes but figured I'd let them handle it, especially if theres a chance it could be something else.
 

bish0p34

Member
Messages
327
You can get in touch with them via Facebook. They're always super helpful. Your warranty is 100% valid, fear not.

And yeah, it sounds like a bad tube. They may not have the longest warranty on them, and they ship with cheap tubes.
 

Motterpaul

Tone is in the Ears
Silver Supporting Member
Messages
13,943
My JCM800 just had a similar issue, and all I did was swap some of the pre-amp tubes around, now it is fine. (I didn't replace any, just repositioned them). It shouldn't happen on new amps, but on older ones tubes can get jostled when moved, and sure, even preamp tubes can cause this. A lot of times it can be a dirty jack, a solder joint or even a fuse.

Send them a support email. Or contact a local amp tech.

FYI: if you are getting some sound but very low, I would try a different V1 tube first. Also check all cables.
 

bish0p34

Member
Messages
327
My JCM800 just had a similar issue, and all I did was swap some of the pre-amp tubes around, now it is fine. (I didn't replace any, just repositioned them). It shouldn't happen on new amps, but on older ones tubes can get jostled when moved, and sure, even preamp tubes can cause this. A lot of times it can be a dirty jack, a solder joint or even a fuse.

Send them a support email. Or contact a local amp tech.

FYI: if you are getting some sound but very low, I would try a different V1 tube first. Also check all cables.


OP, if you try emailing tech support from their website you probably won't get a response. Go to Yorkville or H&K's Facebook page first.
 

gvo369

Member
Messages
14
Just as a followup, I contacted Yorkville Sound USA and spoke with a very helpful representative. After a quick phone call he started a return request ticket for me to get the amp serviced. Turn around time is about a week from them receiving the amp so I'm expecting it back hopefully this week :). I had to pay my own shipping to send it out but the warranty covers return shipping, so all in all I would say the warranty is pretty good considering they will fix whatever is wrong with the unit.
 

Glass Onion

Toneful truth seeker.
Platinum Supporting Member
Messages
9,071
Good news. Hope it all works out. That can be a frustrating situation for sure.
 




Trending Topics

Top Bottom