Valve refuses to glow, but still produces sound?

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by DIXØN, Jul 18, 2008.

  1. DIXØN

    DIXØN Member

    Messages:
    97
    Joined:
    Jun 18, 2008
    Location:
    East Sussex, England
    I have a Laney AOR 30 amp head which I have just refurbished, now the preamp valves are 3x Tube Amp Doctor 12AX7's and one HARMA 12AX7 Cryo in position V1, that is the one that refuses to glow at for about 10 minutes, then glows slightly but not as much as the TAD ones. Is this just because it is a different make, or is it a sign of it being knackered? The sound doesn't seem to be affected, it still sounds very nice although there is not as much gain as I thought there would be, seeing that there are 4 preamp valves...
     
  2. guitarsnguns04

    guitarsnguns04 Member

    Messages:
    982
    Joined:
    Aug 30, 2006
    Location:
    ohio
    I would check the heater voltage under load with that tube in it to see if its drawing it down...its probably in the tube though
     
  3. DIXØN

    DIXØN Member

    Messages:
    97
    Joined:
    Jun 18, 2008
    Location:
    East Sussex, England
    Yeah the heater voltage is fine, the other (TAD) 12AX7's and the two 6V6s are all nice and glowy, in fact they lit up within 10 seconds of turning the power on. So is the HARMA blown or just different? In other words do I need to get another one in there ASAP or is that one fine for a while?
     
  4. JJman

    JJman Member

    Messages:
    992
    Joined:
    Mar 12, 2006
    Location:
    New Jersey
    There are some 12ax7 that appear to be not heated up when running. Only the ends of the filament are visible from the top. I think the EH's are like this? Or were?
     
  5. phsyconoodler

    phsyconoodler Member

    Messages:
    4,351
    Joined:
    Jul 11, 2005
    Location:
    calgary canada
    Sovteks are famous for lack of glow from the filaments.
     
  6. rockon1

    rockon1 Member

    Messages:
    11,479
    Joined:
    Aug 12, 2005
    Location:
    Stamford CT
    Sovtek 12AX7LPS in particular. The heater filaments are hidden from sight . Bob
     

Share This Page