Vox Ac15 problems! help!?

mattreid222

Member
Messages
25
Hey, I've got a vox ac15 and its not turning on anymore, i checked the fuse in the plug and the onboard fuse on the pcb board and they're both fine, the power light is not coming on either, if anyones got any idea what the problem could be it would be very much appreciated, thanks.
 

TopBooster

Member
Messages
194
Is this a 90's reissue, or an AC15CC model?

I'm looking at the 90's reissue schematic and it seems strange that the mains fuse is OK and the power LED isn't illuminating. (This would also be strange for the CC model.) Have you verified with a meter that the mains fuse is not blown? Some fuses can be blown, while still looking perfectly fine. In the meantime, visually check the remaining fuses. On top of the mains fuse (T500mA) and the B+ fuse (T250mA), there should be three T4A filament fuses for the 90's reissue model, and one filament fuse for the CC model.
 

jbltwin1

Member
Messages
282
I think this is the same model I just worked on. Look at the cheapo rectifier tube(if it has one). The one I just did, I THINK, was the ac15 and it had a sovtek(junk) rectifier tube that took out the fuse. It was sparking, popping and in general, just junk. And it was brand new. by the way. Ended up putting in a copper cap and all was fine.
 

dave s

Member
Messages
6,440
If it's one of the CC models, probably the rectifier tube. My CC2 did the same thing. Nothing. No lights, no sound, no dice. It was the rectifier tube.

dave
 

mattreid222

Member
Messages
25
I checked all the fuses i could find with a meter and they were both fine, and its one of the newer chinese made models. I'm probably taking it in to a shop to get it looked at tommorow anyway, thanks for all the replies.
 




Trending Topics

Top Bottom