Vox AC30c2 Hiss.

Discussion in 'Amps and Cabs' started by mourinho, Feb 21, 2012.

  1. mourinho

    mourinho Member

    Messages:
    2
    Joined:
    Jan 7, 2012
    Hi!


    I just received a Vox AC30c2, and let me say that the amp sounds really good, but...


    ... he kind "hisses" a quite bit. Even with nothing plugged he does a strage "waterfall" noise, that goes worst when the "tone cut" knob goes on the trebly side. It's really worst in the "Top Boost" channel then in the normal channel.

    I made a video:
    http://www.youtube.com/watch?v=tHfR938F0o8&context=C35fe14bADOEgsToPDskKhVjGwdfBKJbCw53wbfyT8

    I would like to hear specially from AC30c2 owners. Does your AC30c2 makes this noise too? Is it normal, or my amp is broken?

    Thanks in advance. :)
     
  2. mAx___

    mAx___ Member

    Messages:
    709
    Joined:
    Aug 7, 2011
    It does sound much louder than the normal hiss you could expect of a tube amp. With no guitar connected it should be so low that the camera would not pickup the sound.
    I'd take it back right away for an exchange. Are you in the US?
     
  3. Wayne Alexander

    Wayne Alexander Supporting Member

    Messages:
    1,222
    Joined:
    Nov 1, 2009
    Location:
    Los Angeles
    Swap out the preamp tubes one at a time before doing anything more drastic. Most likely it's one of them.
     
  4. XmasTree

    XmasTree Member

    Messages:
    3,968
    Joined:
    Jan 7, 2009
    Location:
    Clearwater, FL * Tampa Bay Area
    it is most likely a tube

    an amp like that is very unlikely to "break"
    it's probably a bad tube, which is a consumable for amps and are to be replaced once worn out.

    ..a lot of times the manufacturer (Vox, in this case) will put a weak/bad tube in the amp during the build process.
    they're supposed to check for bad tubes but it appears some go by unnoticed.

    this actually happens to a lot of people that buy a new amp.
    it sucks....but.....
     
  5. XmasTree

    XmasTree Member

    Messages:
    3,968
    Joined:
    Jan 7, 2009
    Location:
    Clearwater, FL * Tampa Bay Area
    i just watched your Youtube vid

    that seems normal for an AC30.
    i used to have the AC30 custom classic and it makes some noise
    -especially when you turn the volume all the way up.

    Have you played your guitar with the volume that far up?
    ...they are EXTREMELY LOUD amps...and that hiss is quite normal because they are so powerful.

    Some higher quality tubes may lessen the hiss but everything seems fine..

    how does it sound when you play?
     
  6. mcdes

    mcdes Member of no importance

    Messages:
    7,558
    Joined:
    Oct 9, 2007
    Location:
    New Zealand
    yup, first thing i always do myself, and recommend to others, is to replace all the tubes straight away when you get a new one! it will save you a lot of first up hassles.
     
  7. mourinho

    mourinho Member

    Messages:
    2
    Joined:
    Jan 7, 2012
    Thanks for the help. I'm from Portugal but bought it from England.
    I shipped it yesterday to the store, and they will replace it if there's anything wrong.


    Still, I'd like to know if some one had similar experiences with this amps.
     
  8. ken374

    ken374 Member

    Messages:
    6,331
    Joined:
    May 4, 2011
    Location:
    South East Michigan
    Hey did you play the morgan dag 15 yet? I just did at GC it had a ton of low end and awesome clarity with the Mercury transformers.
     

Share This Page