Wampler and switch problems

Discussion in 'Effects, Pedals, Strings & Things' started by jakob, Apr 14, 2016.

  1. jakob

    jakob Member

    Messages:
    579
    Joined:
    Sep 5, 2006
    Location:
    Iceland
    Aloha.

    I have a Hot wired v2, this is the second time the switch for channel one dies.
    Since I live in Iceland I can't just ship it back to them and they were real nice the
    first time it happened and shipped me a new switch.
    But since this is a recurring problem has anybody fixed this with different switches ?
    I know Wampler will send me new switches if I talk to them but I have to take it to a tech
    and that's going to cost me money, I just want a long term solution since I love the pedal.
    If anybody from Wampler reads this, I'm not trying to flame you, would just like the problem
    to be fixed permanently.:)

    Sometimes the switch works fine and sometimes it cuts my volume in half and I just a low buzzing sound.
     
  2. PBGas

    PBGas Supporting Member

    Messages:
    4,221
    Joined:
    Jul 12, 2009
    Location:
    Ontario, Canada
    Crap....don't like hearing this. My brand new Tumnus has suddenly gone microphonic. I'm starting to wonder on the quality of these things. Love it as a pedal but if this is what I can look forward to then perhaps I made the wrong choice? The warranty is great on these so I'll wait for their response that I sent and go from there.
     
  3. jakob

    jakob Member

    Messages:
    579
    Joined:
    Sep 5, 2006
    Location:
    Iceland
    I also had the Wampler Tape Echo, I returned it to the shop, there was a lot of white noise when it was on.
    In the loop or not, the store didn't believe me and we tried it in a few amps and the noise was in all of them.
    We tried another new one and it had the same white hiss noise, they gave me a deal on El Capistan instead.
    I bought the Hot Wired v2 in Germany so I cant resend it, oh well :)

    So nobody has bought different switches for their Wamplers ?
     
  4. johnh

    johnh Silver Supporting Member

    Messages:
    4,132
    Joined:
    Nov 27, 2006
    Location:
    Belfast, Northern Ireland
    I own several Wamplers, some of which are quite old and have never had a switch problem with any of them.


    However, a footswitch is a moving part and occasional failures do happen - I've had it happen on other pedals; very high quality pedals where I am personally convinced that the switch failure is not any indication of poor quality on the part of the pedal manufacturer.
     
    jakob likes this.
  5. supergenius365

    supergenius365 Silver Supporting Member

    Messages:
    9,039
    Joined:
    Oct 22, 2005
    Contact Wampler directly again. Best way to solve any issue.
     
    jakob likes this.
  6. Memphistokid

    Memphistokid Member

    Messages:
    835
    Joined:
    Nov 10, 2012
    Location:
    Hawaii
    ^^^^This^^^^
     
    jakob likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice