Whats wrong with my phaser??

Discussion in 'Effects, Pedals, Strings & Things' started by wescattle, Feb 5, 2008.

  1. wescattle

    wescattle Member

    Messages:
    392
    Joined:
    Jun 5, 2006
    I was given an old phaser a while ago, prob mid 80s and it worked well for awhile, but now its really shot. It works occasionally, but always has a period of time when it just doesent work, ive tried changing batteries, and opened up the chassis and everything looks solidered on well. So what could it be?

    Thanks for the help
     
  2. wescattle

    wescattle Member

    Messages:
    392
    Joined:
    Jun 5, 2006
    i just tried some stuff, the light works, it clicks on, and it soundes like is ever so slightly phasing, but the knob doesent change anything. IT just isnt phasing, what could cause this problem?
     
  3. dbx

    dbx Member

    Messages:
    2,715
    Joined:
    Jan 21, 2005
    Location:
    En casa, EL A
    What phaser is it? There might be a trimmer inside to adjust the depth...got a pic?
     
  4. GoGoGuitars

    GoGoGuitars Member

    Messages:
    59
    Joined:
    Jun 15, 2006
    Location:
    Long Beach, Ca
    What about an AC option? Does it have one and if so, have you tried it with a power supply?
     
  5. wescattle

    wescattle Member

    Messages:
    392
    Joined:
    Jun 5, 2006
    oh sorry its an MXR phase 90 and i just realized that the brown 'dot' under the knob is snapped off in half, would this effect anything?
     

Share This Page