WTH is up with Red Witch QC???

DivineTones

Member
Messages
1,421
This is the third RW pedal I've had crap out on me in less than a year. The first was the Empress Chorus that I purchased new, and three months later it starts cutting volume by like 75% and giving me difficulties switching. GC gives me a new one. Then I get the Deluxe Moon Phaser. Less than two months after that the same thing starts happening as happened on the chorus. Again, GC switches it out for me. Now the same damn thing is happening on that second Empress Chorus that replaced the original problem pedal! I love these pedals more than just about any other brand, as far as the tone and features go, but for over three-hundred frickin dollars a piece you'd think they'd be more reliable. I'm about to dump this crap construction and go back to MXR.... And always right before a gig!

Anyone else have this problem with their RW pedals???
 

Smgbad

Member
Messages
2,270
Yes. My Empress Chorus did that, and also developed an annoying click that kept time with the modulation everytime the LED would flicker. They told me how to fix it over the phone, and as they thought, it was a bad solder joint. How bad is their QC if they can name the issue without even having to see the pedal?
 

Coiffio

Senior Member
Messages
167
Not me. I own all of their original pedals and haven't had any issues at all with any of them. Sorry to hear about your bad luck. Don't they have a lifetime warranty?
 

Coiffio

Senior Member
Messages
167
Yes. My Empress Chorus did that, and also developed an annoying click that kept time with the modulation everytime the LED would flicker. They told me how to fix it over the phone, and as they thought, it was a bad solder joint. How bad is their QC if they can name the issue without even having to see the pedal?


Seems to me that they know their pedals well is all, and were able to pinpoint the problem over the phone. Seems like good customer service as well.
 

DivineTones

Member
Messages
1,421
Not me. I own all of their original pedals and haven't had any issues at all with any of them. Sorry to hear about your bad luck. Don't they have a lifetime warranty?

I think so, but if it means shipping them back to New Zealand to get the work done.... I've heard they take a while.

Good to hear you've not had any problems. I haven't had any issues with the Pentavocal trem, so let's hope that one breaks my track record.
 

Coiffio

Senior Member
Messages
167
I figured there would be some turnaround time....but its been years that I've owned these pedals and haven't thought about it. best of luck!
 

bodhijames

Member
Messages
73
Moon Phaser crapped out me after six months. It took longer to get replaced than the actual time I had the pedal. Considering the price, very frustrating!

I promptly sold the MP replacement.
 

Smgbad

Member
Messages
2,270
SO that's 3:1 ratio of problems vs no problems from people who have replied. I was on the fence before seeing this, but now... I think I'm done with Red Witch. You can't charge what they charge and have issues like this. I'd expect this from a cheap commercial builder, but not a well-known boutique builder.
 

Coiffio

Senior Member
Messages
167
SO that's 3:1 ratio of problems vs no problems from people who have replied. I was on the fence before seeing this, but now... I think I'm done with Red Witch. You can't charge what they charge and have issues like this. I'd expect this from a cheap commercial builder, but not a well-known boutique builder.


:roll
 

mcdes

Member of no importance
Messages
7,545
ive seen heaps of sparkle drive footswitches go, my Walrus audio voyager footswitch is gone........... maybe the quality of footswitches has gone way down hill..... just a thought.
 

parkhill

Member
Messages
748
I bought a deluxe moon phaser and a empress chorus about four years ago. I sold the chorus after two years. I still own the phaser. Never had a problem with either.
 

Gumbygreeneye

Member
Messages
1,371
Having problems with my Moonphaser. Seems to cut volume when switched on. Never did it to start with. Switching to bypass and the whole signal returns. My local guitar store say they'll take a look at it so I'll take it there next week. I initially had a week or two of thinking it was my patch cable.
 

DivineTones

Member
Messages
1,421
That's exactly the problem. At first it's intermittent, then becomes frequent, and it will start cutting massive amounts of volume. I thought it was my patch cables too, for awhile.
 

Gumbygreeneye

Member
Messages
1,371
Oh I'm so glad it's not just me! (Clearly, I don't want anyone else to suffer ��). I did think I was losing my marbles.

I feel bad for complaining as my local shop is friends with Ben Fulton and when they didn't have one in stock, they called him and sent me one of his own autographed pedals.

I don't mind too much when stuff goes wrong. I've had many electrical items break down over the years and it's the customer service that makes the experience horrible or not. The local shop is great and I'd accept a replacement. If however, like the OP, there was more than one breakdown, I'd certainly lose faith. That'd be only natural.
 

echodeluxe

Member
Messages
1,022
ive seen heaps of sparkle drive footswitches go, my Walrus audio voyager footswitch is gone........... maybe the quality of footswitches has gone way down hill..... just a thought.

ding ding ding!

Jim and I were marveling at the crap quality of the taiwanese 3pdt blue footswitches a couple weeks ago. but its what we got. theres no alternatives. well, no practical alternatives, besides relay based switching, but that adds cost and parts and possible noise etc etc


sigh. it sucks but its what we got fellas.
 

mmolteratx

Member
Messages
2,857
Same issue with both an Empress Chorus and Moon Phaser. Wound up just being crappy joints, but still, like you said, for $300 it's unacceptable for it to happen with that frequency.

ding ding ding!

Jim and I were marveling at the crap quality of the taiwanese 3pdt blue footswitches a couple weeks ago. but its what we got. theres no alternatives. well, no practical alternatives, besides relay based switching, but that adds cost and parts and possible noise etc etc


sigh. it sucks but its what we got fellas.

These are a bit better. At least I haven't had any issues with them, unlike the crappy blue unmarked ones.

http://www.smallbearelec.com/servlet/Detail?no=1324

Mouser sells them too, but they only stock the PC mount version. Bit pricier as well, but saves on shipping since I buy the rest of my stock through them. I'm all about relays the last 7-8 months or so though.
 

mc_deli

Member
Messages
1,238
I was trying the new Synthotron a few weeks ago in a store that had just got it. There were issues straight away with noises in bypass. Really great pedal ideas but something is not quite right as the OP says...
 

Lukeling

Member
Messages
1,547
I had a footswitch problem with my Moon Phaser- sent it back to NZ from Oz & Ben fixed it- shame that the parts problem is sorta out of their hands- great pedal but reliability is paramount when gigging.
 

GTBJ

Member
Messages
462
I have an older (pre-deluxe) chrome Moon Phaser. It has been mine for the last three years or so and is used pretty regularly with no issues.

I have contacted Ben Fulton to ask him some questions about the pedal and the possibility of modding it to add an LED indicator and his response was fast, informative and friendly.

No complaints here.
 




Trending Topics

Top Bottom