• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

YAMAHA THR-II

DNXPeeJay

Member
Messages
7
@ejohnson76 hello friend. I came across your profile on an old post about the THR 10 being stuck in update mode. You were the only person on the internet that I could find with a solution. I have a THR30ii wireless stuck in update mode as well. It was on for the past 15 hours until the battery went out and now I'm able to turn it on and off but it's still stuck in the mode [and now an "A" appears on the tuner occasionally]. I made a reddit post with all of the details I have on my situation here. Any help would be appreciated!

Edit: also accepting help from any other users as well! Just please don't recommend I do anything that void the warranty lol
 
Last edited:

ejohnson76

Member
Messages
429
@ejohnson76 hello friend. I came across your profile on an old post about the THR 10 being stuck in update mode. You were the only person on the internet that I could find with a solution. I have a THR30ii wireless stuck in update mode as well. It was on for the past 15 hours until the battery went out and now I'm able to turn it on and off but it's still stuck in the mode [and now an "A" appears on the tuner occasionally]. I made a reddit post with all of the details I have on my situation here. Any help would be appreciated!

Edit: also accepting help from any other users as well! Just please don't recommend I do anything that void the warranty lol
To the rescue!

Please provide me couple initial info to sort your problem out.

1. If you turn on the unit, what you see is "U" in the tuner? Please describe what happens when you power cycle the unit.
2. Can you try updating the firmware again using the THR Remote?

Thanks (And don't worry, it's going to be okay)

JK
 

DNXPeeJay

Member
Messages
7
To the rescue!

Please provide me couple initial info to sort your problem out.

1. If you turn on the unit, what you see is "U" in the tuner? Please describe what happens when you power cycle the unit.
2. Can you try updating the firmware again using the THR Remote?

Thanks (And don't worry, it's going to be okay)

JK
1. Now when I turn on the unit, I don't even get the U on the tuner anymore. It only shows as an "A" now.

2. Can't try updating the firmware again because neither my PC or Mac detect the device in the THR Remote app
 

ejohnson76

Member
Messages
429
1. Now when I turn on the unit, I don't even get the U on the tuner anymore. It only shows as an "A" now.

2. Can't try updating the firmware again because neither my PC or Mac detect the device in the THR Remote app
Thanks, try following procedures and let me know how it goes.


- First, make sure that your THR is connected with the power adapter and turned OFF.

1. Download and install the THR Remote to your Mac from following URL. (v1.1.1)
https://usa.yamaha.com/support/updates/thr_remote_mac.html

PC :


2. Connect the THR and Mac (or PC)

2. Turn on your THR holding the TAP/TUNER and the USER MEMORY 1 button to boot in the update mode.

3. Observe the tuner window. If you see "U", wait until you see small arrows appear like below.



4. Launch the THR Remote app you just installed.

5. Find the icon that looks like guitars. It's on the upper-left side of the app.




6. Press Command(⌘) + Click the guitar icon and you will see "Force Update THR amp". Click it.
(Ctrl + Click for PC)



7. Your will see a green dot flashing on the "U" in the tuner window. It will take couple minutes( approx 2 mins) to update. After that, you will see "E" "n" "d" in the window. It will shutdown automatically. THR Remote will show the progress and update end message like below.




8. Turn on your THR and and check briefly it's normal.

9. Close the THR Remote app and disconnect THR from Mac. Turn off the THR.

10. Now, you MUST update your THR again to update your G10T. Please follow the instruction that you tried.( https://usa.yamaha.com/news_events/2020/0200_thr_caution.html ) You can start from the step 3.

Don't worry, it will be okay! Just continue updating on your Mac. I guess some hiccups happened on your PC, especially USB side. Make sure, keep your G10T connected to the THR during the entire update process until you see the message that everything has been done.

11. Annnd, please let me know how it goes!
 
Last edited:

DNXPeeJay

Member
Messages
7
Thanks, try following procedures and let me know how it goes.


- First, make sure that your THR is connected with the power adapter and turned OFF.

1. Download and install the THR Remote to your Mac from following URL. (v1.1.0)
https://usa.yamaha.com/support/updates/thr_remote_mac.html

2. Connect the THR and Mac

2. Turn on your THR holding the TAP/TUNER and the USER MEMORY 1 button to boot in the update mode.

3. Observe the tuner window. If you see "U", wait 3 seconds.

4. Launch the THR Remote app you just installed.

5. Find the icon that looks like guitars. It's on the upper-left side of the app.




6. Press Command(⌘) + Click the guitar icon and you will see "Force Update THR amp". Click it.



7. Your will see a green dot flashing on the "U" in the tuner window. It will take couple minutes to update. After that, you will see "E" "n" "d" in the window. It will shutdown automatically.

8. Turn on your THR and and check briefly it's normal.

9. Close the THR Remote app and disconnect THR from Mac. Turn off the THR.

10. Now, you MUST update your THR again to update your G10T. Please follow the instruction that you tried.( https://usa.yamaha.com/news_events/2020/0200_thr_caution.html ) You can start from the step 3.

Don't worry, it will be okay! Just continue updating on your Mac. I guess some hiccups happened on your PC, especially USB side. Make sure, keep your G10T connected to the THR during the entire update process until you see the message that everything has been done.

11. Annnd, please let me know how it goes!
I got up to step 7 in your process. THR Remote told me that I will see the U with the blinking light for a few minutes and that it would shutdown automatically. It's currently been 12 minutes and the dot above the U is still blinking; this is what happened last time. I'm going to leave it on and plugged in to my computer until you give me direction as to what I should do next.
UPDATE: The THR Remote app crashed, the U with the blinking dot is still going on. I have tried turning off the amp but now it's in the same state it was yesterday where nothing will affect it. I will be unplugging the charging wire because it took 15 hours for it to die yesterday and I would rather just have it drain itself quicker and then I can always plug it back in to charge when it's dead
 
Last edited:

ejohnson76

Member
Messages
429
I got up to step 7 in your process. THR Remote told me that I will see the U with the blinking light for a few minutes and that it would shutdown automatically. It's currently been 12 minutes and the dot above the U is still blinking; this is what happened last time. I'm going to leave it on and plugged in to my computer until you give me direction as to what I should do next.
UPDATE: The THR Remote app crashed, the U with the blinking dot is still going on. I have tried turning off the amp but now it's in the same state it was yesterday where nothing will affect it. I will be unplugging the charging wire because it took 15 hours for it to die yesterday and I would rather just have it drain itself quicker and then I can always plug it back in to charge when it's dead
That's odd.. the remote shouldn't say anything about "U" and blinking because it's an update through rescue mode. Also, it shouldn't take more than 2 minutes. I just tested it using my MacbookPro and confirmed it took about 1:30. Just in case, Remote's version is v1.1.0 and you're using Mac, right?

Let me update my procedure(step 3 and 7) to make sure couple more things. I totally understand that it's annoying and time consuming, but if it stuck again, please redo with the updated procedure. Sorry that you needed to get through this!
 

DNXPeeJay

Member
Messages
7
That's odd.. the remote shouldn't say anything about "U" and blinking because it's an update through rescue mode. Also, it shouldn't take more than 2 minutes. I just tested it using my MacbookPro and confirmed it took about 1:30. Just in case, Remote's version is v1.1.0 and you're using Mac, right?

Let me update my procedure(step 3 and 7) to make sure couple more things. I totally understand that it's annoying and time consuming, but if it stuck again, please redo with the updated procedure. Sorry that you needed to get through this!
Ok awesome. Let me know when it [your procedure] is fully updated. And to clarify by what I meant earlier where I referenced the THR Remote saying it will "stop blinking," I was actually referncing to this screenshot of yours
Link
 

ejohnson76

Member
Messages
429
Ok awesome. Let me know when it's fully updated. And to clarify by what I meant earlier where I referenced the THR Remote saying it will "stop blinking," I was actually referncing to this screenshot of yours
Link
Already updated. Check to see if the screenshots were what you saw. As you can see, the app won't say anything about blinking... Also confirming the issue with the team in Japan.
 

DNXPeeJay

Member
Messages
7
Already updated. Check to see if the screenshots were what you saw. As you can see, the app won't say anything about blinking... Also confirming the issue with the team in Japan.
Just read your updated procedure and I followed everything you said to a perfect T. I'm stuck where it says "THR will turn off automatically when the update is complete." I clicked "Ok" and have been waiting for it to turn off ever since
Currently, the U is still lit on the tuner, the green dot is still blinking, I am unable to turn off the unit, I am unable to re-try any of your steps, and I have unplugged the unit from the wall to stop it from charging because I have a feeling I may just have to let the battery run out again.
Any other actions I can take currently?
 

ejohnson76

Member
Messages
429
Just read your updated procedure and I followed everything you said to a perfect T. I'm stuck where it says "THR will turn off automatically when the update is complete." I clicked "Ok" and have been waiting for it to turn off ever since
Currently, the U is still lit on the tuner, the green dot is still blinking, I am unable to turn off the unit, I am unable to re-try any of your steps, and I have unplugged the unit from the wall to stop it from charging because I have a feeling I may just have to let the battery run out again.
Any other actions I can take currently?
Oh snap, sorry to hear that.. :( there's not much things to try as far as I know. I will to talk to the team in Japan in a few hours and get back to you ASAP. Please leave the unit unplugged from the power adapter.
 

ejohnson76

Member
Messages
429
Oh snap, sorry to hear that.. :( there's not much things to try as far as I know. I will to talk to the team in Japan in a few hours and get back to you ASAP. Please leave the unit unplugged from the power adapter.
Just in case, could you provide me about your Mac? Something like, Macbook Pro 2018, 15 inch, etc.
 

DNXPeeJay

Member
Messages
7
Just in case, could you provide me about your Mac? Something like, Macbook Pro 2018, 15 inch, etc.
MacBook Pro (Retina, 15-inch, Mid 2014) running macOS Mojave Version 10.14.6 with a 2.8 GHz Intel Core i7 processor, 16 GB 1600 MHz DDR3 memory, and a NVIDIA GeForce GT 750M 2 GB Intel Iris Pro 1536 MB graphics card.

As some bonus information, Yamaha Electronics Support emailed me and said that it's possible this could happen if you try to update the firmware on a THR unit that came with a "white dot" on the bottom of it. My unit doesn't have the white dot but I wonder if it was in fact one of those units but that mine just came without the proper label. Idk if that information helps at all but I figured I would share anyway.

Lastly, thank you for helping me out! I will regularly check this thread in case you develop any updates.
If for some reason you and Yamaha Electronics Support can't help me figure it out, I am covered under warranty correct? [unit arrived to my house from Sweetwater in mid-january]
 

ejohnson76

Member
Messages
429
MacBook Pro (Retina, 15-inch, Mid 2014) running macOS Mojave Version 10.14.6 with a 2.8 GHz Intel Core i7 processor, 16 GB 1600 MHz DDR3 memory, and a NVIDIA GeForce GT 750M 2 GB Intel Iris Pro 1536 MB graphics card.

As some bonus information, Yamaha Electronics Support emailed me and said that it's possible this could happen if you try to update the firmware on a THR unit that came with a "white dot" on the bottom of it. My unit doesn't have the white dot but I wonder if it was in fact one of those units but that mine just came without the proper label. Idk if that information helps at all but I figured I would share anyway.

Lastly, thank you for helping me out! I will regularly check this thread in case you develop any updates.
If for some reason you and Yamaha Electronics Support can't help me figure it out, I am covered under warranty correct? [unit arrived to my house from Sweetwater in mid-january]
Thanks!

The white dot seal means it has the latest (v1.31) firmware and I'm sure it has nothing much with your issue. Not sure about the Sweetwater warranty, but I believe most of major dealers should cover it. Anyway, please stay tuned.
 

ejohnson76

Member
Messages
429
MacBook Pro (Retina, 15-inch, Mid 2014) running macOS Mojave Version 10.14.6 with a 2.8 GHz Intel Core i7 processor, 16 GB 1600 MHz DDR3 memory, and a NVIDIA GeForce GT 750M 2 GB Intel Iris Pro 1536 MB graphics card.

As some bonus information, Yamaha Electronics Support emailed me and said that it's possible this could happen if you try to update the firmware on a THR unit that came with a "white dot" on the bottom of it. My unit doesn't have the white dot but I wonder if it was in fact one of those units but that mine just came without the proper label. Idk if that information helps at all but I figured I would share anyway.

Lastly, thank you for helping me out! I will regularly check this thread in case you develop any updates.
If for some reason you and Yamaha Electronics Support can't help me figure it out, I am covered under warranty correct? [unit arrived to my house from Sweetwater in mid-january]
I've just had a talk with the team, and confirmed that there is no issue(like yours) reported yet. They suspected the flash memory itself was a faulty one, unfortunately. I strongly recommend you to contact the dealer and get a replacement shipped to you. The warranty should cover it. I'm sorry that I couldn't help you sorting it out. Please let me know if you have any questions.
 

DNXPeeJay

Member
Messages
7
I've just had a talk with the team, and confirmed that there is no issue(like yours) reported yet. They suspected the flash memory itself was a faulty one, unfortunately. I strongly recommend you to contact the dealer and get a replacement shipped to you. The warranty should cover it. I'm sorry that I couldn't help you sorting it out. Please let me know if you have any questions.
Just contacted both Yamaha support and Sweetwater to figure out what the next steps are. Thank you for being of so much help and reassurance; I really appreciate it!
 

Bobisadrummer

Member
Messages
125
Checked my email around 5pm EST today and saw an email from Sweetwater at 11:45 saying these were back in stock but they're already sold out again with everywhere saying the end of june/july for more. Awesome.
 

Andre BS

Member
Messages
155
Today I tested recording with my thr10II for the first time. No problem with Cubase, everything was smooth and easy. I compared it with some recordings of my 10 and 10x and the 10II definitely sounds better. I'm really happy!!!:) Huge improvement!
 

chris81

Active Member
Messages
38
Today I tested recording with my thr10II for the first time. No problem with Cubase, everything was smooth and easy. I compared it with some recordings of my 10 and 10x and the 10II definitely sounds better. I'm really happy!!!:) Huge improvement!
Absolutely. And you definitely can get the same or even better brown sound like on the old 10x model by eq-ing and fiddeling with the master and gain. If someone turns it on (all knobs on half-way) and expects it to sound the same like it did on the 10x, that’s just not the case. I guess those who returned it right away because of that, just didn’t put enough time in it. I LOVE IT! Thinking about making a little A/B sound comparison USB vs. TRS-line-out-recording quality, to help some of you guys decide if it’s for you or not. At least for me the recording quality definitely was a point for my buying decision...
Chris
 

ejohnson76

Member
Messages
429
Hello Mr. Kim,
could you list what specific artists/album/song sounds you have been going for with the factory presets? Most of them sound really great in my oppinion... good job!
Chris
So do you have the list of amps of each Pesets ? :)
also, is you Private preset pack ready ?
Here's the factory preset explanation notes. Hopefully, it could help you understand the presets better. If you want to download the document, click the "pop-out" button on the upper right of the document, then download it from the Google Drive.


Please feel free to let me know if you have any questions.

My private presets will be shared soon, sometime early next week.
 
Last edited:






Trending Topics

Top Bottom